Email not being delivered to users [SOLVED]

OS type and version AlmaLinux 8.7
Virtualmin version 7.8.2

I have searched for this solution for 3 straight days, both online and in this forum, and THIS particular solution was no where to be found so I created an account just to post this as a possible solution for others who may be stumped by it.

Mine is a relatively new VPS with a fresh install of Virtualmin and Webmin. Moving from a cpanel setup back to Virtualmin after about 15 years of not using it. So I’m not completely new to it, but it’s been a while. There are several domains running on it, each with various email accounts.

For some of the domains the main user account gets email as well as users. All email accounts are set up through Virtualmin, nothing manually done. The main account for each domain can send and receive email without a problem. The user accounts can send email. I can even log in via Usermin and using Thunderbird and send email. But none of them could receive email. All attempts bounced with the message: “User unknown in virtual alias table”.

I think I read every post on this forum and many others looking for the solution. I have a FQDN, commented out the myorigin line in, made various other changes to various conf files. All of the recommended things that seemed to resolve the problem for others. Rebooted postfix after each change. Rebooted the server numerous times. Nothing worked. And I was close to throwing in the towel and going back to cpanel.

While snooping around yet one more time out of desperation and in spite of “Insanity is doing the same thing over and over and expecting different results”, I noticed in Virtualmin, under one of the domains with a problem, in the “Edit Mail Aliases” section, clicked on the user that was not getting email and found:
“Deliver locally - Yes, deliver to mailbox” was not checked
“Forward to other address - Yes, forward to addresses” WAS checked and had the email address in question as the forward.

This didn’t make sense. So I tried reversing that. Checked “Deliver locally - Yes, deliver to mailbox” and entered the email. Unchecked “Forward to other address - Yes, forward to addresses”.


That was it all along. I’ve looked at the Virtualmin templates and so far can’t seem to find where or even why this was set up this way from the beginning. Maybe someone else will know the answer for that.

Anyway, for those who have tried everything else, maybe this will help.


Normally aliases don’t have a mailbox, so normally uncheck. By default there is 4. abuse@ hostmaster@ etc.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.