Email issue

(and i’ve checked the docs this time :wink: )

I host several domain names using virtualmin, and have overcome lots of issues (mostly common sense ones) to get all running well.

However, one thing i can’t seem to sort is with a mail issue.

A couple of the domains use thier own mail servers and i’ve set the MX records appropriately.
Emails to and from those domains to external (ie not hosted on my server) come and go happily, as expected.

However, if i send from an internal domain to one that’s got the DNS on my server, but the MX on their own server, it bounces…

This is the mail system at host .

I’m sorry to have to inform you that your message could not
be delivered to one or more recipients. It’s attached below.

For further assistance, please send mail to

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

               The mail system

<BOUNCE@> (expanded from ):
unknown user: “bounce”

it’s as if it’s ignoring it’s own MX record and trying to deliver it locally.

Is there anything i can do to force it to recognise the MX records?



btw - running Centos 5.4 64bit


It sounds like although the MX for those domains are elsewhere, there are still local mail entries for it that are causing problems.

Are you sure that in Edit Virtual Server, that the “Mail for Domain” feature is disabled?


Hi Eric

mail for domain definitely disabled for all those with separate mail servers

but still if the mail is sent from the server itself (using webmail / usermin) it still doesn’t get there but bounces back!


Yeah, if there’s some stray entries for your domain in there, that would cause the bounces you’re seeing.

If you take a look at /etc/postfix/virtual, do you see the domain in question listed in there anywhere? There shouldn’t be any mention of it since it’s hosted elsewhere.

If you do see an entries mentioning that domain, try removing them, save the file, then run “postmap /etc/postfix/virtual”, and see if that does the trick.


ah - spotted it - but not sure why it was there

the ‘offending’ domains were listed thus:


Removing those, and running “postmap /etc/postfix/virtual” as suggested has worked

Thanks for your help