Email from Client doesn't always work

If I access my mailbox with usermin or Roundcube there are no problems.
If instead I try from Thunderbird (version 115.9), sometimes I send mail, but I don’t receive it or I neither send nor receive it. At other times I send and receive.
The Thunderbird error message is that the server is not responding.
This happens both by sending to external emails and to other mailboxes in the domain.

In /var/log I don’t see mail.log
Where do I find the logs?

OS type and version Debian 12
Webmin version 2.105
Virtualmin version 7.10
Related packages email

I’m guessing Debian 12 uses the newer logging of systemd and not rsyslog?

Test with telnet.

How did you configure your SMTP server? Or are the configs all default so far?


Use the proper server and ports to avoid conflicts.

If you have SSL/TLS enabled, port is 993 (incoming). For outgoing, 465.

Try setting up your IMAP account on Gmail, they handle improper configuration with more feedback.

Yours sincerely,

I confirm that I cannot find the logs.
I used the standard configuration, I didn’t make any changes to Postfix.
For the Client (Thunderbird in Win11Pro) I use the settings that are reported in “Email Client Settings”.
IMAP server port: 993
Use SSL for IMAP: Yes
SMTP server port: 587
SMTP encryption type: STARTTLS
Even with the 465 the mail doesn’t go out.
If sometimes it works and sometimes it doesn’t, it shouldn’t be a parameter problem.

Even from Telnet “open mail.domain.tld” doesn’t work.

I tried from a Linux VM and everything worked.
I tried again from Win11Pro but now using a new Thunderbird Portable and with a clean configuration, but it still doesn’t work.

I should now understand if in Linux it worked occasionally because previously on Win11 it worked sometimes yes or sometimes no.
I’ve been using Thunderbird for years on this PC until yesterday morning without ever having had any problems and I see no reason why Windows is now blocking it.
I also tried deactivating Windows Firewall Defender while the only notifications reported on the PC are Thunderbird messages received.

I try using Thunderbird in the Linux VM to see if it continues to work or if it still crashes there too.
I’m keeping the post on hold.

a long shot, do you have an aggressive firewall in-between thunderbird and your webserver?

Roundcube and Usermin are both based on the server whereas Thunderbird is not.

In theory there should be no active firewall on this server. I will ask for more information.
But even if this were the case it should always be blocked, not “sometimes”.

Depends on blocking time outs and if if is specific to a particular service.

Try adjusting your Postfix settings with the examples below. You can find these settings in Webmin.

Do not forget to click the button “Reload configuration” after.

This should work with the virtualmin/webmin defaults surely this indicates some other issues?

It’s a nightmare!
When it works (and it doesn’t always work) the settings to enter in the client are different from those that appear in “Show Email Client Settings”.
Here there is IMAP server hostname = mail.domain.tld and instead it works with domain.tld, without “mail.”.

I use the standard settings so I don’t have to customize them. However, even the suggested changes do not change the situation.
The provider tells me that there is no active firewall of theirs and therefore everything is still managed by Virtualmin where I have not changed anything yet, neither under File2ban nor under FirewallD.

But where is the log?
I only find /var/log/procmail.log where there are errors, but they are related to something else (I think).
In any case I don’t understand why it works and doesn’t work within a few minutes.

Apr  4 00:09:13.808 [40471] warn: check: dns_block_rule URIBL_BLOCKED hit, creating /home/domain/.spamassassin/ (This means DNSBL blocked you due to too many queries. Set all affected rules score to 0, or use "dns_query_restriction deny" to disable queries)
From MAILER-DAEMON  Thu Apr  4 00:09:11 2024
 Subject: Undelivered Mail Returned to Sender
  Folder: /home/domain/Maildir/new/1712182153.40452_0.hostname	   4703

What error do you get? Do you have an A record in DNS for mail.domain.tld? Is that name included in your certificate?

In Thunderbird it simply doesn’t connect all the time, but sometimes.
The A record exists.
Which certificate are you talking about?

That can’t be configuration on the server. That has to be…something else.

Maybe all of your DNS servers don’t have the A record for this hostname. Maybe your system is running out of memory and the OOM killer is randomly killing mail processes. I dunno. Intermittent problems are not generally configuration problems, though.

Check the mail log (or journal for the relevant mail units) for clues.

The server has 32GB RAM and is not working yet.

I opened the post just asking for the logs.
I can’t find them anywhere; progmail.log only

Modern systems send most logs to the journal. You should get familiar with it (the journalctl command is the standard tool for searching/tailing logs in the journal). The postfix, dovecot, and saslauthd units are probably the relevant ones for your problem.

Webmin has the System Logs Viewer module that defaults to include the journal (instead of the System Logs module, which works with various syslog implementations). But, for anything complicated, the journalctl command is still your most capable option.

Forgive me, Joe, I agree with you.
I also agree in thinking that if I want to work on a server I must have technical knowledge.

However, I hope that you equally agree with me that if I work on a “panel”, whether it is called cpanel, directadmin, plesk or virtualmin, it is to have a simpler life.
So, if I create the domain “” and then the user “john.doe”, I expect to be able to immediately load the website that is already running somewhere else and to be able to immediately receive mail .

Then, if one is capable, one goes to play with the configurations, otherwise one is satisfied with the default configurations.
And don’t waste days figuring out what’s going wrong and having to buy an avalanche detection dog to look for the problem.

I’ll stop here for the moment.
I continue with cpanel because I have to work and use email.

I will install Virtualmin in a test environment.
I was too hasty (and perhaps too optimistic) to expect to immediately install it in a production environment and see it work immediately.

I thank everyone for their collaboration.
See you again later.

your expectations are not too optimistic. :o)
it should run out of the box.
I’m sure there is a simple explanation but as you say finding it may not be easy.

did you use to run some checks on the server. (again appreciate you have gone back to cpanel but worth checking that for any configuration issues - e.g. is there two DNS servers and one not setup the same)

i check the logfile : /var/log/maillog