Email error: TLS not available due to local problem. how to fix

SYSTEM INFORMATION
OS type and version centos 7 min
Virtualmin version 7.5

i get the error TLS not available due to local problem while trying to send mail from thunderbird how to fix this does require a starttls certificate and if yes how to create it

thanks

nikos

We need to see the exact errors, and the related entries from the mail.log for the session you’re trying to initiate (don’t send the whole log, just start tailing the mail.log and then initiate your connection in Thunderbird, and send the half-dozen or so messages in the log that the attempt to connect generates).

where is mail.log do you need maillog from /var/log?

thanks

nikos

Yes. It’s /var/log/maillog.

Use sudo tail -f /var/log/maillog
and then only copy relevant entries as Joe mentioned.

mail-log.zip (440 Bytes)

here is the file tail of maillog in /var/log

A warning that precedes this event is mentioned in log. Can you please find it in the log and post it here?

log.zip (789 Bytes)

take a look here and if you need something because i don’t know well what to do here please give me some more details what to give you specific details

thanks

nikos

These warnings mentioned in the log are not related to the issue you are facing right now.

I have find around the web this example:

EXAMPLE:
warning: No server certs available. TLS won’t be enabled


warning: Wrapper-mode request dropped from mail.server.com[X.X.X.X] for service smtps. TLS context initialization failed. For details see earlier warnings in your logs.

Also, your configuration file located in /etc/postfix/main.cf can give us some clue. Just remove your personal informations like your IPs and domains :slight_smile:

I think that the issue will be related to badly configured SSL/TLS, Cert, etc.

It “maybe” you didn’t add the cirt for postfix. (if your using letsencrypt)
In SSL section for the domain do you see the blue button?

problem solved, it was to set the default services certificate for everything to function correctly