Edited config file manually to change webroot, Virtualmin became inaccessible

Operating system: Debian 10
OS version: 10
I’m installing a script that has to have it point to the path /public directory.
I changed the path in .config file to /home/*****/public_html/public
Now my virtualmin wont work on on port 10000.

Hello @jwhisenhunt and welcome to the community.

Change the config file back to what it was.
Then, at the CLI:
sudo service webmin restart - check if Virtualmin now shows on port 10000

In future, use Virtualmin -> Server Configuration -> Website Options: Website documents sub-directory to point webroot to the public_html//public directory.

That change is unrelated to Virtualmin being inaccessible.

Check the Webmin error log (/var/webmin/miniserv.error, probably) for why it failed.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.