Dumping MySQL error on backup: errno32

Hi guys, my backups are not done. When executing a backup I get this error:

Copying Logrotate configuration …
… done

Dumping MySQL database wordpress …
… dump failed!

Password: su: Authentication failure
mysqldump: Got errno 32 on write
Dumping MySQL database 000555_roundcube …
… dump failed!

Password: su: Authentication failure

They have always worked perfectly. I can not find the solution to the problem.

This is the result for recheck configuration, all like well:

The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active …
Your system has 15.71 GB of memory, which is at or above the Virtualmin recommended minimum of 256 MB.
BIND DNS server is installed, and the system is configured to use it.

Mail server Postfix is installed and configured.

Postfix can support per-domain outgoing IP addresses, but is not currently configured to do so. This can be setup in the Postfix Mailserver module.

Apache is installed.

The following PHP versions are available : 5.6.38 (/usr/bin/php5-cgi), 5.6 (mod_php)

PHP-FPM support was not detected : No FPM configuration directory found

Webalizer is installed.

Apache is configured to host SSL websites.

MySQL is installed and running.

ProFTPD is installed.

Logrotate is installed.

SpamAssassin and Procmail are installed and configured for use.

ClamAV is installed and assumed to be running.

Plugin DAV Login is installed OK.

Plugin AWstats reporting is installed OK.

Plugin Mailman is installed OK.

Plugin Protected web directories is installed OK.

Using network interface eth0 for virtual IPs.

IPv6 addresses are available, using interface eth0.

Default IPv4 address for virtual servers is XXXXXXXXXXXX.

Default IPv6 address for virtual servers is XXXXXXXXXXXXXx

Default IP address is set to XXXXXXXXXXXXXXX, which matches the detected external address.

Both user and group quotas are enabled for home and email directories.

All commands needed to create and restore backups are installed.

The selected package management and update systems are installed OK.

Chroot jails are not available : The Jailkit command jk_init was not found on your system - maybe the jailkit package is not installed?

However, if I try to make a backup through CLI, the systema always ask for a password:

virtualmin backup-domain --dest /home/backups/migrate/ --all-domains --all-features --newformat --all-virtualmin
Starting backup…
Creating backup for virtual server xxxxxdomain.com
Copying virtual server configuration …
… done

Backing up Cron jobs ..
.. none defined.

Copying records in DNS domain ..
.. done


¿Any idea? Thanks in advanced


It looks like you’re seeing an authentication issue there:

Password: su: Authentication failure

Are you performing this as the root user, or as the Virtual Server owner?

And is it possible that the password for this particular MySQL user was changed outside of Virtualmin?

Hi, i work as root user in both: cli and virtualmin panel. To make sure for a correct password, I’ve even run the install wizard but the error is still

I try to make a backup as Virtual Server owner and get the same error

Dumping MySQL database wordpress …
… dump failed!

Password: su: Authentication failure
mysqldump: Got errno 32 on write

Are you seeing this issue just with one particular domain?

If it’s just happening with just one, that may mean the password Virtualmin has stored for that database is out of sync. You can always try going into Edit Databases -> Passwords for that domain in Virtualmin, and reset the password there.


Thanks in advanced for your time Eric.
I Work in root mode: It’s happening in all domains with database.
From root user Virtualmin, I try to change the database password and the issue is the same. As root mode from webinterface and CLI, and as domain owner from virtualmin