dump failed! su: user does not exist

I recently moved an account with several sub-servers from one virtualmin server to another. On the new server I renamed the user account from to . Everything seems OK aside from the scheduled backup reports the following error for the server and each subserver:

dump failed! su: user does not exist

I’ve checked everywhere in Virtualmin and can’t find any references to so I assume this is set in a in a config file somewhere?

Hmm, it does sound like the old username may still be lingering around somewhere.

What you tried should be safe to do, so we’ll look into that and see if we can reproduce a similar problem.

In the meantime though, you may want to take a look at the config files for those domains. You can do that by going into /etc/webmin/virtual-server/domains. Each file in that directory represents a domain in Virtualmin.

What you can do is grep those files for the old username.

Now, you may want to make a backup before any changes are made. But what you could try doing there is changing any references in those config files from the old name to the new one.


That seems to have worked, thanks. I had to replace the old username with the new in user=, ugroup=, group= and mysql_user=

I noticed that the top-level domain which was changed wasn’t affected, but all sub-servers were. We had a setup something like

mydomain.com (Top-Level)
  myolddomain.com (old domain name, alias)
  api.mydomain.com (sub-server)
  dev.mydomain.com (sub-server)
  demo.mydomain.com (sub-server)

Only api, dev and demo were affected.

I’d used the virtualmin option to change username on the top level server, which I had assumed would filter down to the sub-servers as they all share the same database credentials, but it looks like it didn’t.

Not sure if it’s related but I also use phpMyAdmin as root to rename the databases and then imported them back into virtualmin via the web interface.

I also noticed on the top level server, the ssl_chain= option was still set to the old username, which caused apache not to restart after editing the apache configuration since the CA file could not be found.