dpkg version

Hello there,

It seems that Ubuntu 10.04 users will be left behind starting from Virtualmin 5.03 and Webmin 1.801 (the last versions to date) as the dpkg version of that distribution is 1.15.5 and it only handles gzip and not xz compression.
I tried to manually update dpkg after updating tar from 1.22 to 1.25 but I didn’t succeed.
Below is the output I get when I try to update Virtualmin (it’s pretty much the same result for Webmin):

Building dependency tree…
Reading state information…
The following packages will be upgraded:
1 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Need to get 0B/1617kB of archives.
After this operation, 0B of additional disk space will be used.
(Reading database … 120535 files and directories currently installed.)
Preparing to replace webmin-virtual-server 5.02.gpl (using …/webmin-virtual-server_5.03.gpl_all.deb) …
Unpacking replacement webmin-virtual-server …
dpkg-deb: file `/var/cache/apt/archives/webmin-virtual-server_5.03.gpl_all.deb’ contains ununderstood data member data.tar.xz , giving up
dpkg: error processing /var/cache/apt/archives/webmin-virtual-server_5.03.gpl_all.deb (–unpack):
subprocess dpkg-deb --fsys-tarfile returned error exit status 2

Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
… install failed!

Any thoughts?


Unfortunately, Ubuntu 10.04 reached it’s EOL in April of last year – it’s no longer supported by Ubuntu or by Virtualmin:


Since the distro isn’t receiving any updates, including security updates, we would highly recommend updating to an Ubuntu LTS version that is supported by Ubuntu.

That said, nothing was intentionally changed to prevent Ubuntu 10.04 from working. I’ll talk to Joe to make sure the above isn’t a bug. But if Ubuntu 10.04 is the only place that’s being seen, it’s probably not something that will be corrected… sorry!