Dovecot will break if you upgrade Sarge -> Etch

Syntax changes from 0.99 to 1.x in the /etc/dovecot/dovecot.conf file. You’ll need to comment out:

auth = default
auth_userdb = passwd
auth_passdb = pam

and replace them with:

auth default {
mechanisms = plain
userdb passwd {
passdb pam {
args = session=yes *
args = *

user = root

That got dovecot working again for me. Prior to that it wouldn’t start with error messages about “Unknown settings”.

Hope this saves someone a headache.