Dovecot server won't start after installation of VM

Guys, it’s been a while since I did an installation, however, after installing a fresh copy, Dovecot stopped working and it won’t restart. I’ve tried deleting and re-installin VM, but it stops anyway. Could someone please point me in the right direction to fix it? TY

Operating system Ubuntu Linux 22.04.4
Webmin version 2.111 Usermin version 2.010
Virtualmin version 7.10.0 Authentic theme version 21.10

I’m sorry, what? Surely you didn’t run the Virtualmin install script on a production system (ignoring all the warnings to not do that)?

What do you mean by “installing a fresh copy”?

You need to look at the logs.

systemctl status dovecot

journalctl --since="-1d" -u dovecot

Maybe you also have a mail.log.

Thank Joe. Now, I can’t get Putty to login… Will do as soon as I’m able and get back.

BTW, I’m trying out a new server and it’s not too friendly so far. The server is Contabo.

Contabo historically didn’t play very well—we had plenty of users with various sorts of issues. Have you tried Linode or Vultr?

No. I’ve been using Tier.net for my sites and it’s been very good. I have a client that went into Contabo and wants me to install VM on it. So far has been a two day affair…

I’m on my last try. I’ve reinstalled Ubuntu 22.04 without a panel, and now I’m installing VM from your code: sudo sh -c “$(curl -fsSL https://software.virtualmin.com/gpl/scripts/virtualmin-install.sh)” – --bundle LAMP
If this doesn’t work, then I’m done. Also, after installing VM, do I still update the server, or does VM do it? TY

Virtualmin does it upon installation process.

I did an installation, however, after installing a fresh copy,

Can you unpack that? Did you install Virtualmin on clean Ubuntu 22.04 instance?

I installed again in a fresh instance. So far is ok.

It will be okay as long as you don’t restore old configs for services like Dovecot, Postfix, Apache and etc from old backups – just restore the virtual servers (domains).

O.K. One question. Where’s the install script for php 7 located? TY

It’s right here:

Thanks. O.K. It just stopped Dovecot again. And it happened when I hit Re-Check Configuration. The status of your system is being checked to ensure that all enabled features are available and properly configured

You can run systemctl restart dovecot followed by systemctl status dovecot to get more details about what’s wrong.

This is what I got back:

Job for dovecot.service failed because the control process exited with error code.
See “systemctl status dovecot.service” and “journalctl -xeu dovecot.service” for details.
root@vmi1877539:~# systemctl status dovecot.service
× dovecot.service - Dovecot IMAP/POP3 email server
Loaded: loaded (/lib/systemd/system/dovecot.service; enabled; vendor preset: en>
Active: failed (Result: exit-code) since Fri 2024-05-17 20:37:14 EDT; 8s ago
Docs: man:dovecot(1)
https://doc.dovecot.org/
Process: 67772 ExecStart=/usr/sbin/dovecot -F (code=exited, status=89)
Main PID: 67772 (code=exited, status=89)
CPU: 24ms

May 17 20:37:14 vmi1877539.contaboserver.net systemd[1]: Starting Dovecot IMAP/POP3 >
May 17 20:37:14 vmi1877539.contaboserver.net dovecot[67772]: doveconf: Fatal: Error >
May 17 20:37:14 vmi1877539.contaboserver.net systemd[1]: dovecot.service: Main proce>
May 17 20:37:14 vmi1877539.contaboserver.net systemd[1]: dovecot.service: Failed wit>
May 17 20:37:14 vmi1877539.contaboserver.net systemd[1]: Failed to start Dovecot IMA>

Can’t update VM because it’ll stop Dovecot

Look at the dang log. Restart the service and then look at recent log entries.

It’ll either be /var/log/mail.log or journalctl -u dovecot --since="-5m"

TY Joe. I only have var/log/nobody