Dovecot / Postfix & creating new email account


I’ve got a little bit of a problem, cannot find the answer myself so I hope anyone here can point me into the right direction.

I’m using Virtualmin 3.53 GPL on a fully updated CentOS 5.1 installation. For email handling I am using Dovecot and Postfix.

When I create a new Virtual Server and want to add a new email account afterwards the POP3/FTP login for the email account is only <user> and not <user>@<domain>.

So obviously this is causing problems when 2 domains want to create an email account with the same <user> before the @<domain>.

Can someone tell me what settings to change so the newly created email/ftp accounts will get the full <user>@<domain> to login?



it’s set in your default server template under mail for domains.

Hope that helps,

Module Config->Defaults for new domains->Include domain name in usernames? = Yes

Though, if it doesn’t automatically switch to appending the domain name, it’s a bug, and ought to get fixed. Though you need to update to 3.54.

As Dan mentioned, you can also configure the style of the domain name (.domain, -domain, @domain.tld, etc.) in the Server Templates.

Thanks for the answers guys.

After changing these settings everything worked fine.
But because today I suddenly noticed that awstats wasn’t functioning anymore, I did a complete fresh reinstall, so after that I needed to change these settings again and now everything works fine out-of-the-box with CentOS 5.1 with the latest updates and Virtualmin 3.54 GPL.

The last 2 months I did a lot of testing (I never worked with Virtualmin before), this server is going to be placed in a datacentre near me in a couple of weeks, so today was the right time for a fresh installation :wink: