Dovecot error- could start after installation

Operating system:
OS version:
Operating system CentOS Linux 7.9.2009
Webmin version 1.973 Usermin version 1.823
Virtualmin version 6.16

Hello Friends
I am not expert in Linux,
i couldnt start Dovecot IMAP/POP3 Server
I read and tried most forums posts
but failed
i need to send receive emails
thank you

Hello @elhassan, we will try to help get Dovecot online.

When you hit the Start Dovecot Server button, what do you see on the page that follows?

thanks for reply
I find this error

Failed to start Dovecot :

doveconf: Fatal: Error in configuration file /etc/dovecot/dovecot.conf line 154: ssl_key: read(/etc/dovecot/) failed: Is a directory

This :point_up_2: seems to be the cause of the problem.

You will have to edit /etc/dovecot/dovecot.conf and correct / remove line 154 (actually the entire block around line 154). The file can be edited via Webmin → Tools → File Manager. Be careful with the editing, this is an important file. Always backup a config file before you edit.

If you feel you are unable to carry out this operation and don’t mind the idea of a stranger logging into your system, send me your credentials via private message and I will fix it for you.

thanks for help
let me try it first

You are most welcome, @elhassan, my friend.

I am sure you will succeed in fixing it yourself. That’s how we all learn.

1 Like

local_name {
ssl_cert = </ssl.combined
ssl_key = <

ssl_key = <

do I delete it?!!

I have a problem with SSL in main server

trying to fix it with domain hosting provider

I was expecting local_name <domain_here> {

Anyway, remove the entire block below and start Dovecot

local_name {
ssl_cert = </ssl.combined
ssl_key = <

Let’ see if this does not fix the problem.

I removed the whole section
still the error message is

Failed to start Dovecot :

doveconf: Fatal: Error in configuration file /etc/dovecot/dovecot.conf line 154: ssl_key: read(/etc/dovecot/) failed: Is a directory

That’s the same error as the initial one. You did say you are not an expert, so I ask: did you save the file dovecot.conf after you edited it?

I downloaded the original in PC

after editing I saved the file and closed it

After you saved the file and closed it on the PC, did you upload it back to the server?

the PC for backup and is the original setting

in server was edited and saves on server

the new Line 154 is

local_name *. {
ssl_cert = </ssl.combined
ssl_key = <

the difference from the first is in first line

Ok, you did the right thing to backup on your PC and edit on the server.

From the line local_name *. {, I infer that you are attempting to use a wildcard SSL.

If so, could you test if Dovecot works with a standard SSL for the domain instead of a wildcard?

Again I say, I was expecting that line to be something like: local_name *.<domain_here> {

ok calpot I will test it

i am deeply sorry I have to go for 1 Hr
I will continue and I wish to complete the issue since I was working on it for a week

bye for now

Bye bye!

Post must be 12 characters. Why not 8?

CALPORT YOU ARE A ROCK :slight_smile:

i deleted the whole section

i found the next section containing the domain name, as you expected

there was a ( } ) missing so I added it

it worked after one week struggle and 5 min of CALPORT :slight_smile: THANKS

im glad you fixed your issue, btw centos is not linux its unix…have great day.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.