I have a problem while connecting to dovecot server from windows7 to linuxOS.

on the client side i use windows7 where my application is run, whereas on server side i use linuxOS where dovecot is installed.

when i connect through telnet 143 port (from windows7 to linux)i get following error:

Connecting to…Could not open connection to the host , on port 143:connection failed

but when i try to connect between linuxOS(both server and client are RHEL) the connection gets established, but the connection remains stabilised for few minutes only nevertheless i reconnect it.

Could any one help me!! i need to fix this issue immediately.

thank you,


Hmm, I’m not able to connect to port 143 on that IP address either… that could mean that there is some sort of firewall/router problem, or there could be a configuration issue with Dovecot.

Is this server directly on the Internet? Or is it behind a NAT router? If it’s behind a NAT router, is port 143 being forwarded from the router to your server?



The server is neither on the internet nor behind a NAT router… it is on our LAN connected to a switch…
Firewall has been disabled on the server and client…

I have tried connecting from thunderbird as well… but the same problem persists…
It works fine from linux to linux though…
I presume Dovecot has been configured correctly since it works from a linux system…

Is there any special setting in Dovecot to specifically enable windows clients??

Appreciate your help in this regard…



Dovecot just listens for incoming connections, it doesn’t distinguish between the OS that is connecting.

My suggestion would be to make sure the port that is being used from Windows is the same as the one that you’re connecting to from Linux.



We are connecting on port 143 in both the cases…

Dovecot does not differentiate between OS or software used on the client machine. If you can connect to port 143 on your server from one machine, but not from another, it’s probably a networking issue.

There indeed seems to be an issue with the IP address you mentioned in your first post. Like Eric, I cannot reach that IP with ping or mtr from neither my home DSL or my root server (located at a German hoster). The routing path stops at the outbound point of the respective ISP.

Further analysis shows:

IP address Reverse DNS (PTR record) not available DNS server (NS record) not available ASN number not available, IP is not in the global routing table.

You might want to ask the ISP responsible for this IP range (“Gestión de direccionamiento UniNet” according to Whois) why the IP is not in the global routing table, thus unreachable from the Internet.

when i run the application on client side(Windows7) and give the “tcpdump -i eth0” command on server side(linux OS) and check for packet flow, i found the following details:

09:36:27.295156 IP (tos 0x0, ttl 128, id 2177, offset 0, flags [DF], proto TCP (6), length 40) > Flags [.], cksum 0xcb36 (correct), ack 1, win 16425, length 0
09:36:27.297858 IP (tos 0x0, ttl 64, id 23770, offset 0, flags [DF], proto TCP (6), length 149) > Flags [P.], cksum 0x346d (incorrect -> 0xe362), seq 1:110, ack 1, win 46, length 109
09:36:30.297177 IP (tos 0x0, ttl 64, id 23771, offset 0, flags [DF], proto TCP (6), length 149) > Flags [P.], cksum 0x346d (incorrect -> 0xe362), seq 1:110, ack 1, win 46, length 109
09:36:36.297164 IP (tos 0x0, ttl 64, id 23772, offset 0, flags [DF], proto TCP (6), length 149) > Flags [P.], cksum 0x346d (incorrect -> 0xe362), seq 1:110, ack 1, win 46, length 109

here,> client>server

i am unable to rectify where exactly i am losing connectivity.
could you please suggest me

when the connection fails i get the following error message on client side

javax.mail.MessagingException: * BYE JavaMail Exception: Connection reset; nested exception is: com.sun.mail.iap.ConnectionException: * BYE JavaMail Exception: Connection reset at com.sun.mail.imap.IMAPStore.protocolConnect( at javax.mail.Service.connect( at javax.mail.Service.connect( at mail.ClientActions.login( at mail.MailView.submitActionPerformed( at mail.MailView.access$900( at mail.MailView$6.actionPerformed( at javax.swing.AbstractButton.fireActionPerformed( at javax.swing.AbstractButton$Handler.actionPerformed( at javax.swing.DefaultButtonModel.fireActionPerformed( at javax.swing.DefaultButtonModel.setPressed( at javax.swing.plaf.basic.BasicButtonListener.mouseReleased( at java.awt.AWTEventMulticaster.mouseReleased( at java.awt.AWTEventMulticaster.mouseReleased( at java.awt.Component.processMouseEvent( at javax.swing.JComponent.processMouseEvent( at java.awt.Component.processEvent( at java.awt.Container.processEvent( at java.awt.Component.dispatchEventImpl( at java.awt.Container.dispatchEventImpl( at java.awt.Component.dispatchEvent( at java.awt.LightweightDispatcher.retargetMouseEvent( at java.awt.LightweightDispatcher.processMouseEvent( at java.awt.LightweightDispatcher.dispatchEvent( at java.awt.Container.dispatchEventImpl( at java.awt.Window.dispatchEventImpl( at java.awt.Component.dispatchEvent( at java.awt.EventQueue.dispatchEvent( at java.awt.EventDispatchThread.pumpOneEventForFilters( at java.awt.EventDispatchThread.pumpEventsForFilter( at java.awt.EventDispatchThread.pumpEventsForHierarchy( at java.awt.EventDispatchThread.pumpEvents( at java.awt.EventDispatchThread.pumpEvents( at Caused by: com.sun.mail.iap.ConnectionException: * BYE JavaMail Exception: Connection reset at com.sun.mail.iap.Protocol.handleResult( at com.sun.mail.imap.protocol.IMAPProtocol.authplain( at com.sun.mail.imap.IMAPStore.login( at com.sun.mail.imap.IMAPStore.protocolConnect( ... 33 more

Is your server by chance running a firewall of some sort? What is the output of this command on your Virtualmin server:

iptables -L -n

Also, I don’t imagine there’s any additional information in the mail logs, are there? Does anything show up in /var/log/maillog when trying to connect from your Windows email client?