Dovecot.conf problem after update [SOLVED]

I have just upgraded Debian Squeeze > Wheezy. Dovecot is now version 2.1.7.

When starting Dovecot you will get warning about the syntax of the dovecot.conf file. With a version of the file automatically updated by Dovecot I get a Perl exception in Usermin. With a manually config’d file I could not get auth working, connection was always refused. With the default conf file supplied I could not get correct maildirs working. Studying the documentation did not enable me to sort it out because I was could not find documentation on the auth setup which works with Virtualmin.

If anyone can offer advice about how to the mod the dovecot.conf file to get rid of the syntax warnings, that would be welcome. However, the old version of the file is working. My advice to others contemplating this upgrade is to ignore the syntax warnings when starting Dovecot, and don"t mess with the file, or at least be sure to take a backup copy before changing it. I did have to uncomment the lines pointing to ssl certificates to get Dovecot to start, but beyond that an untouched file kept from the pre-upgrade version was the only way I could get Dovecot working.

[EDIT] For others having problems, the doveconf script which autogenerates a conf file compatible with the new version does work. It was a long night… don"t manually edit the conf file if you are tired…j

Maybe this will change when Virtualmin package is released for Wheezy, but for now Just run the script which generates and updated conf file:

doveconf > dovecot.conf-new

mv dovecot.conf dovecot.conf-backup

mv dovecot.conf-new dovecot.conf

service dovecot restart (or /etc/init.d/dovecot restart should do it: if not just put back your backed up file and ignore the warnings, it still worked but only with the paths to SSL files uncommented)

During the upgrade process, it would prompt you what to do with your Dovecot config… whether to use a new config file, or to keep your existing config.

Which option are you suggesting worked for you here?

We had noticed some problems as well with the Dovecot upgrade process, and would certainly like to make this as smooth as possible for folks.

-Eric

I elected to keep my configuration.

I do not recall that it offered to keep the config but correct the syntax of the config file. I did and would always elect to keep the existing config, because I do not have the knowledge of Virtualmin to expect to get a a fresh config working fast.

When you restart Dovecot with the old config file it puts out a lot of warnings and a too-brief message drawing attention to the doveconf command. It could at least refer to the man pages. What might be nice is a script which runs doveconf to create a new config file but keeps a copy of the old file just in case.

There is a default conf file at /usr/share/doc/dovecot-core/example-config/dovecot.conf.gz which when unzipped and used dovecot starts cleanly without warning but Usermin / mail clients / telnet give me connection refused on 110 and 143 and mail log gives messages about not finding a passwd file in passdb

Also upgrading Dovecot from cli it too me a while to figure out that you select the supported languages with space bar: hitting enter without selecting with space bar first does not work.

I will not go into the full upgrade experience because I assume you are not planning to suppor a major version in-place Debian upgrade via Virtualmin / Webmin, just Dovecot. One of the other problems was that it baled out on upgrade mysql with
“Depends: mysql-client-5.5 (>= 5.5.30+dfsg-1.1) but 5.5.30-1~dotdeb.0 is installed.” although I have always been able to update mysql with apt-get in the past.

FWIW I also had one unmet depedency.

The upgrade required numerous iterations of apt-get upgrade and apt-get dist-upgrade.

At one time I could not start Apache with a message could not bind to port 8081 (which is what I use for Apache) but I could not work out why: reboot fixed it.

Your documentation might add that upgrade kernel and udev may not be necessary on a VPS.

I would not really attempt an in-place major version Debian upgrade on a server with client sites unless it had the bootable disk-image type of backup, as some of the better quality VPSs offer, so in worst case everything can be restored within an hour or so. I fire up this restore to recover the working dovecot.conf after my attempts to correct the syntax rendered it faulty.

I will not go into the full upgrade experience because I assume you are not planning to suppor a major version in-place Debian upgrade via Virtualmin / Webmin, just Dovecot

That should indeed work (once Wheezy is formally supported), and we’re working on documentation to assist with that.

You can see that documentation here:

https://www.virtualmin.com/documentation/system/os/debian-squeeze-to-wheezy-distupgrade

Though, as I read your last comment, it sounds like you may have seen that.

I’ll do some additional testing with the Dovecot config though, in order to make sure that ports 110 and 143 are enabled.

Thanks for all your comments and insight!

-Eric

I encountered the new Dovecot configuration a short while back while installing it from backports. It was a little hurdle, but not too bad using the doveconf generator.

However, now testing the Debian upgrade, I cannot get the dist-upgrade to complete successfully, even when choosing the new package configuration option. (Note the appearance of 3 way merge experiment, which I haven’t tried yet)

Still puzzling it out …

Are you getting no error message? Does apt-get --verbose-versions help?

I found that when the dist-upgrade baled out with a package conflict on mysql or an unmet dependency, it did not skip the problem package but just stopped and would not restart till the issues were resolved. But apt-get dist-upgrade did give me error messages.

Incidentally before starting I had already upgraded all software to latest versions including Mysql 5.5 and php 5.4. Maybe that helps.

Hi John_B,

I got a clean dist-upgrade after moving dovecot’s SSL certs into /etc/dovecot and /etc/dovecot/private.