Domain name changed in Virtualmin

OS type and version REQUIRED

Operating system CentOS Linux 7.9.2009
| Webmin version | REQUIRED |
Webmin version 1.994
| Virtualmin version | REQUIRED |
Virtualmin version 7.1 Pro
| Related packages | SUGGESTED |
after a lock up of the server - after rebooting, one of my domain names has disappeared from the list of the Virtualmin servers. The domain and email seem to be working fine, however the name itself is gone from the list.
I think however, it might have been renamed as the domain id now shows:
Domain ID 13160548969372
It should be vintagedesigns
The reason I think it is this one as Vintagedesigns had two sub domains under it and they are now under this new number.
My question is, how can I fix this without breaking the domain and losing the contents please?

domain ID is always a number. Maybe recheck config.


thanks, but I’m talking about the drop down list in Virtualmin - see attached. That shows the 131… number it should show

Thats beyond my knowledge. Did you try recheck config

yes, I’ve already tried that - it made no difference sorry.

can you ask another support team person please - as I need to have this fixed.

Is there anything interesting in any of the following?




still exist in its proper form?

Does cat /home/vintagedesigns/.virtualmin-src

reveal an ID that matches what you’re seeing in the list and what’s on the virtual server summary.

Does cat /etc/group reveal an entry for

vintagedesigns:x:nnnn:apache ?

Does the virtual server domain have proper entries in DNS?

How about httpd.conf ? Is the ServerName value correct?

To be clear, I’d just be poking around looking for clues. I have no idea how to fix this at this point.

And I’d just be looking. I wouldn’t go anywhere near a text editor just yet.


[root@hosting webmin]# less miniserv.error
[27/Apr/2020:20:09:16 +1000] started
[27/Apr/2020:20:09:16 +1000] IPv6 support cannot be enabled without the Socket6 perl module
[27/Apr/2020:20:09:16 +1000] Using SHA512 module Crypt::SHA
[27/Apr/2020:20:09:16 +1000] Perl module Authen::PAM needed for PAM is not installed : Can’t locate Authen/ in @INC (@INC contains: /usr/libexec/webmin /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 14) line 1.
BEGIN failed–compilation aborted at (eval 14) line 1.

[root@hosting webmin]# less miniserv.log - - [27/Apr/2020:20:51:59 +1000] “GET / HTTP/1.1” 401 4787 - - [27/Apr/2020:20:51:59 +1000] “GET /unauthenticated/css/bundle.min.css?19469999999999901 HTTP/1.1” 200 138323 - - [27/Apr/2020:20:51:59 +1000] “GET /unauthenticated/css/fonts-roboto.min.css?19469999999999901 HTTP/1.1” 200 381093 - - [27/Apr/2020:20:51:59 +1000] “GET /images/favicons/webmin/favicon-32x32.png HTTP/1.1” 200 1787 - root [27/Apr/2020:20:52:22 +1000] “POST /session_login.cgi HTTP/1.1” 302 0 - root [27/Apr/2020:20:52:23 +1000] “GET /unauthenticated/css/bundle.min.css?19469999999999901 HTTP/1.1” 200 138323 - root [27/Apr/2020:20:52:23 +1000] “GET /unauthenticated/js/defaults.js?19469999999999901 HTTP/1.1” 200 5026 - root [27/Apr/2020:20:52:23 +1000] “GET /unauthenticated/css/fonts-roboto.min.css?19469999999999901 HTTP/1.1” 200 381093 - root [27/Apr/2020:20:52:23 +1000] “GET /unauthenticated/js/bundle.min.js?19469999999999901 HTTP/1.1” 200 475566 - root [27/Apr/2020:20:52:23 +1000] “GET /images/favicons/webmin/favicon-16x16.png HTTP/1.1” 200 1146 - root [27/Apr/2020:20:52:23 +1000] “GET / HTTP/1.1” 200 68980 - root [27/Apr/2020:20:52:24 +1000] “GET /extensions/stats/stats.min.js?19469999999999901 HTTP/1.1” 200 2517

nothing really in webmin.log

YES: /home/vintagedesigns exists still.

YES: [root@hosting home]# cat /home/vintagedesigns/.virtualmin-src

YES: cat /etc/group

SuexecUserGroup “#1162” “#1039
DocumentRoot /home/vintagedesigns/public_html
ErrorLog /var/log/virtualmin/
CustomLog /var/log/virtualmin/ combined
ScriptAlias /cgi-bin/ /home/vintagedesigns/cgi-bin/
ScriptAlias /awstats /home/vintagedesigns/cgi-bin
DirectoryIndex index.html index.htm index.php index.php4 index.php5
<Directory /home/vintagedesigns/public_html>
Options +Indexes +IncludesNOEXEC +SymLinksifOwnerMatch +ExecCGI
allow from all
AllowOverride All Options=ExecCGI,Includes,IncludesNOEXEC,Indexes,MultiViews,SymLinksIfOwnerMatch
AddType application/x-httpd-php7.4 .php7.4
AddType application/x-httpd-php .php
Require all granted

<Directory /home/vintagedesigns/cgi-bin>
allow from all
AllowOverride All Options=ExecCGI,Includes,IncludesNOEXEC,Indexes,MultiViews,SymLinksIfOwnerMatch
Require all granted

Alias /dav “/home/vintagedesigns/public_html”
Alias /pipermail /var/lib/mailman/archives/public
Alias /mail /usr/share/roundcubemail
<Location /dav>
AuthType Basic
AuthUserFile /home/vintagedesigns/etc/dav.digest.passwd
Require valid-user
ForceType text/plain

RedirectMatch /cgi-bin/mailman/([^/])(.) “$1.cgi$2
RedirectMatch /mailman/([^/])(.) “$1.cgi$2
#PerlRequire /etc/webmin/virtualmin-google-analytics/
#PerlOutputFilterHandler Virtualmin::GoogleAnalytics
#PerlSetVar AnalyticsID UA-11031594-1
#PerlSetVar ClickyID 100820486
#PerlSetVar HeadJavascriptFile /etc/webmin/virtualmin-google-analytics/13160548969372.head.js

AuthName “ statistics”
AuthType Basic
AuthUserFile /home/vintagedesigns/.awstats-htpasswd
require valid-user

#php_value memory_limit 128M
<Proxy *>
allow from all

php_value memory_limit 32M
php_value magic_quotes_gpc Off

AuthName “ statistics”
AuthType Basic
AuthUserFile /home/vintagedesigns/.awstats-htpasswd
require valid-user

Okay. Copy the ID number and:

cat /etc/webmin/virtual-server/domains/[ID number]

Is the value for dom correct? (Should be the domain name.)

Tried that then:
[root@hosting steve]# cat /etc/webmin/virtual-server/domains/13160548969372
[root@hosting steve]# service webmin restart
Redirecting to /bin/systemctl restart webmin.service
[root@hosting steve]#
Still the same though: (see attached)

Was the entry for dom there or did you add it? I wonder if it’s a generated file.

Okay, I’m out of ideas. If any come to me in my sleep (which sometimes happens – I live a boring life), I’ll hop back on. Hopefully someone else will come along before then and help you get this sorted out.


Have you seen these:

1 Like

I think you need to tag @staff I think for them to be notified, I’m just a user.


thanks mate - found this:
virtualmin restore-domain --source /backups/ --domain --feature virtualmin --fix

that fixes it.


Yes, that command is the right solution to restore a corrupt file in the domains directory.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.