domain migration from cpanel backup to Virtualmin when real IP is behind NAT

Please answer as soon as possible as we are running out of time.

We have Webmin and Virtualmin installed on our server Ubuntu 12.04.
We are trying to migrate and configure Domain in Virtualmin from cpanel backup.

Here is the IP situation:

Primary Interface IP
Externally Visible IP address which is behind NAT
(above IPs are just for example).

we are able to connect to this server from out site via
and we can manager whatever we want.

Here is our problem:

Whenever I migrate Domain from cpanel back using Virtualmin> Add server > migrate virtual server templet. We are able to migrate but website does not open up through any Browser from anywhere.
Let say migrated domain is
While migrating we have tried both IP options given in the templet i.e
“Shared IP”
and Virutal IP also checked on Aready Active.

In our option DNS is being managed somewhere else and all record for exist there itself. is maped to
Also let us what DNS records should be in Virtualmin if there is need according to you for

Please let us if issue is with the IP and if yes, what is the solution?
Please help us how we can migrate our Domains in such IP situations. Help is with the options if there is need to map local interface IP with real IP behind NAT.

Thank you!


I would recommend setting it up using the shared IP address.

However, you’d also need to configure your server so that in System Settings -> Virtualmin Config -> Network Settings, “Default IP address for DNS records” would need to be set to “Automatically detect external address”.

Without that setting, the DNS records wouldn’t be returning the correct public IP address.


Thanks for your help Howdy but we are still not done.

We did as you suggested.
Our cpanel back also contains DNS records and while migrating they all configured automatically in the virtualmin and point to

Do we need to delete these DNS records from the virtualmin as they already exist outside ?
We have tried both ways i.e. we tried deleting DNS records from virtualmin and let them be there…but none works !

Our Problem remains same. We have been able to migrate the domain data and when we click Preview Website it works locally but never works when we try to open from outsite.

please help us !


If you aren’t using your server as a DNS server, you’d want to disable the “BIND DNS Domain” feature for that domain.

You can do that in Edit Virtual Server -> Enabled Features.

That will remove the DNS zone (and all the records) for that domain.

But that doesn’t sound like the problem you’re having.

When you say “it doesn’t work” – what is the exact problem you’re experiencing? Are getting any errors? Are you seeing another site? Is it timing out?