Domain invalid - subdomain issue

SYSTEM INFORMATION
OS type and version ubuntu 24.04
Webmin version 2.111

This is my hostname set for webmin

upon checking the same url it is redirecting me to site1

I had completed this setup couple of days ago and during the setup it was running as expected. but now is redirecting to site1 instead of webmin dashboard

please suggest.

Records for subdomains

Note: I have used subdomain for webmin as well.

Record for Webmin subdomain

using http://IP:10000 it is working as expected.
Can i add nginx to same server and proxy it to 10000 or how shall i fix this.
Nginx and apache on same host caused port conflict last time as both webserver listens on port 80.

if you turn off proxy does it work ok.

1 Like

generally speaking “no” you cannot have nginx on an apache server and you should be asking “Why on earth?” - they both do the same job (but in different ways).

1 Like

Tried turning off proxy, currently set to DNS only. Still the same.
My main concern is i am getting redirected to site1(dot)domain(dot)com when i enter webmin(dot)domain(dot)com
i want subdomain webmin.domain.com to point to webmin dashboard.
I had created 2 virtualservers using virtualmin out of which site1(dot)domain(dot)com is one and another one is site2(dot)domain(dot)com

that redirect already happens. Looks like webmin.example goes to usermin, you can edit that though to go to port 10000

still not working tried commenting the rewrite to 10000 still getting redirected to site1

This is the access log for site1 all the request under webmin are getting serverd by this.
i hope this helps.

Not sure what you done, looks a mess.

I would try removing that sub domain, this assumes you created it using virtualmin or it has an apache configuration file, that is loaded. All domains created via virtualmin will configure the correct redirection for each domain. So you may find that admin.webmin.domain.tld works, again assuming virtualmin created the domain

Assuming that you are using cloudflare by this image you have uploaded

Please read through this page about ports available in cloudflare.
https://developers.cloudflare.com/fundamentals/reference/network-ports/

You need to log into your webmin and change the port access number to one that cloudflare supports, preferably the https list such as port 8443.

After changing the Webmin port to one that cloudflare supports, you will still need to enter the new port number after like this: (https://webmin.domain.com:8443)

Hey everyone,

I’ve been following the discussion about the “domain invalid” and subdomain issues, and I appreciate all the insights shared here. I wanted to ask if anyone has encountered similar problems specifically when migrating domains between different hosting providers. Are there any best practices or steps that you recommend to ensure a smooth transition without running into these validation errors?

Looking forward to your suggestions!

Most issues appear to be the user thinking they know better than virtualmin, do some off roading and fail ! However if you read what is in front of you and apply the default template everything works