Domain has disappeared from user's account, and can't import it

Hello, a domain has disappeared from Virtualmin: the user’s account says “you do not manage any domains” and it isn’t in the drop-down when logged in as root.

I tried “Import virtual server” and it found all the data, but I receive the error:

Creating directories under home directory
… done

HTTP/1.0 500 Perl execution failed Server: MiniServ/1.580 Date: Fri, 6 Apr 2012 14:00:18 GMT Content-type: text/html; Charset=iso-8859-1 Connection: close
Error - Perl execution failed

Undefined subroutine &bind8::list_slave_servers called at /usr/share/webmin/virtual-server/import.cgi line 283.

What’s happened to this missing domain? Thanks.


Does it help to restart Webmin?

You can do that by running the following command:

/etc/init.d/webmin restart


Unfortunately not, that doesn’t make any difference.


I have now tried making a new account under a different username but this won’t work because I get “the domain xyz is already hosted by your DNS server”.

Do I need to manually remove all aspects of this account using Webmin and then re-create from Virtualmin? Frustrating that Virtualmin would forget about the account like this.

The most recent version of Virtualmin seems to have fixed the Import bug (though no idea if the bug that caused the account to disappear has gone).