Does webmin modules get automatic updates

OS type and version ubuntu 22.04
Webmin version 2.102

I want to know does webmin modules get updates just like other package updates. Like here i can see all the modules with last modified date Index of /download/modules
i want to know when an module update is available then will it be shown in virtualmin or webmin. Thankyou


Depending on the module owner and type of module, generally speaking yes.

Modules developed by the Virtualmin team like those developed by Jamie are generally maintained as often as necessary. Some may seem out of date perhaps because they are not popular or simply don’t require an update.

Modules developed by third parties are updated as often as that party updates. While there are useful third party modules, it would be a good idea to keep in touch with module developer as some do get discontinued without notice.

Is there any particular module you have questions about?

Thankyou for reply. I want to know if an update is available then how can i update the module in webmin. Will i get an update notification or its updated automatically or do i have to manually download and upload it to update it.

Be specific about which module you mean. Most of those modules are in Webmin, and so updating Webmin will always update to the latest version of that module.

Unable to Update Virtualmin Module from “Update modules” tab of “Upgrade Webmin”

Webmin does not detect the availability of the updated 7.8.2 version of Virtualmin for display on the Dashboard. Trying to upgrade the Virtualmin module from the “Update modules” tab of the “Upgrade Webmin” page in “Webmin Configuration,” either with the default Update from radio button selected, or the “Update from other sources…” radio button selected and either “” or “” entered into the text box returns “Updating Webmin modules … No Webmin updates for this version.” Virtualmin was originally installed from “” using the “Install Module” page.

Webmin version 2.102
Authentic theme version 21.06
Kernel and CPU FreeBSD 13.2-RELEASE-p3 on amd64
Virtualmin version 7.7

Did you try Refresh Available Packages at Webmin–>System–>Software Package Updates?


FreeBSD does not have a package manager supported by Software Package Updates. Nothing you do in Software Package Updates could do anything useful on FreeBSD.

Last time I tried to deal with FreeBSD packages, the package manager situation was dire. It just didn’t work beyond the most basic initial installation…even upgrades to binary packages with no changes (i.e. not a custom ports build or whatever) sometimes broke random packages that depended on the package being upgraded (in one case, an OpenSSL upgrade broke every package that used SSL, unless they were rebuilt from ports). At the time, you pretty much used ports for everything or you didn’t have a functional FreeBSD system. I have been told that that is no longer the case and FreeBSD has a decent package manager now. We just don’t have enough FreeBSD users to justify the high cost of supporting it more fully. (Back when we did support it, FreeBSD took more of my time than all the Linux distros combined, in terms of packaging and installer support, for a variety of reasons…many of those reasons aren’t a problem anymore; no more need for a custom kernel or Apache, maybe no more need for a custom Postfix, etc. Given we only had a handful of paying customers using FreeBSD, it just wasn’t sustainable.)

Note that the initial poster and the subject of this thread does not seem to be about FreeBSD, though, so let’s not change the subject. OP needs to fill us in on what module they’re trying to update and how they installed, because we’re all guessing and can’t possibly offer useful advice.

That URL is the second of the two previously tried which failed. I included that URL in my previous message. I am wondering whether the switch to semantic versioning underlies the inability to detect that a version update of a module is available. It seems that there is currently no way to use Webmin to update modules, and that the only alternatives are to either reinstall modules or obtain updated standard modules as part of a Webmin update. There must be a module update problem that needs to be fixed.

I should note it seemed appropriate to specify that the machine is running FreeBSD, however, it seems very unlikely that the inability to update modules is related to the OS. The FreeBSD package management system is not implicated at all. I install Webmin and Virtualmin directly from the official .wbm files. If the FreeBSD packaged versions are installed, then updates have to await updated packages. The file hash comparisons regularly and automatically performed by the package management system will detect and report Webmin self-updates as extreme corruption. Hash comparison is a quite excellent security feature of the FreeBSD package management system, yet it makes mixing packaged and non-packaged software installations or updates particularly inappropriate. As an aside, we have been using the FreeBSD package management system for nearly seven years with perfect results. Also, the Webmin Software Package Updates feature has always worked properly with FreeBSD.

OK, I’m pretty confident your issue is unrelated to the original issue that opened this topic (though we’re still waiting on OP to explain the problem with specificity). I want to loop Jamie in on this, as it does sound like a version comparison bug in the Webmin modules upgrade process, but I don’t want to hijack this thread with unrelated discussion. So, maybe you can open a new topic about your specific problem so I can ping Jamie about it?

See: Unable to Update Virtualmin Module from “Update modules” tab of “Upgrade Webmin” · Issue #641 · virtualmin/virtualmin-gpl · GitHub

I extend apologies to the OP if my messages hijacked this discussion in any way. That was not my intent. The problem that I discovered seemed likely to be pertinent.

1 Like