Does Virtualmin have Cloudflare DNS support yet?


According to this comment here: Virtualmin --dns cloudflare-dns [#33619] | Virtualmin

The next version of Virtualmin should have had Google DNS and Cloudflare support several months ago.

Does it have support for those yet or did they run into issues implementing it? Should they be in the list of Cloud DNS Providers or somewhere else or nowhere?

I setup a new Virtualmin server to play with since I haven’t used it for awhile and it seems like people are still manually adding DNS entries to Cloudflare from what I can see in posts on these forums.

I was recently playing with WordOps and it seemed kind of nice except that the maintainer apparently doesn’t have much time for it anymore. It has an option where you can verify Let’s Encrypt through DNS automatically through Cloudflare which is pretty neat. I wonder if I can use it with Virtualmin somehow.

It would of course also be very convenient to automatically manage not only Let’s Encrypt verification but all of the DNS entries in Cloudflare through Virtualmin instead of having to go into Cloudflare.

Another thing I saw that did this but had some issues was a panel called YunoHost. It will try to add entries into Cloudflare when you add domains to it. It gives you a sort of “diff” looking view and an option to overwrite them and a button to add them.

I don’t know if any of that is useful in some way but just thought I’d share my experiences in case it helps get those features in there somehow or another. I’m sure they’re probably working on it still among many other things since they’re always adding neat things and fixing stuff.

Thank you for your time!

Virtualmin Pro has Google and Cloudflare DNS support. Pretty sure it’s in 6.17.


And, 7 is coming in a couple days. If it’s not in 6.17 Pro (though I think it is), it’s definitely in 7.


Well then looks like I’ll have to order me a copy of Virtualmin Pro again and see what else is new. Thank you kind sir!

I’ve used Cloudflare on my Virtualmin GPL install since day one.

That was about two years ago.

This question is about Virtualmin managing Cloudflare DNS, not about using Cloudflare as a proxy for Virtualmin-managed sites (with manually managed DNS). We’ve been adding support for cloud-based DNS services that have an API, like Amazon Route 53, and Google Cloud DNS. Cloudflare is one of them.

I tried it out but it wouldn’t work for me. I tried posting a ticket as per the support page so hopefully I did that right at least. Is there documentation somewhere for it? I couldn’t find anything. I must be doing something wrong.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.