Does Virtualmin (free) work seemlessly on Rocky Linux 9.1 ? ( -> Wordpress)

Rocky Linux 9.1 REQUIRED
7.0.0 Current Dec 2022

because my installation failed on Rocky Linux 9.0 LEMP Version, I shall now reinstall Rocky Linux 9.1.

Did you have a positive (worked out of the box) or medium (worked w/manual fixed) or negative experience using the 7.0.0 script ?

I am an expert on CMS , so I may have made some mistake…and frankly excepted that NGINX worked “out of the box” the web site (on localhost:10000) did not.

How to debug may be my problem.
The documentation here may nor be good enough (for me !).

Thanks for posting !

9.0 and 9.1 are the same. That’s the point of a long-life distro like Rocky. If there are problems, they will occur on either 9.0 or 9.1, almost certainly.

I just realized you said you have a problem on 9.0. If you have a problem you need to tell us what it is.

thanks for the quick reply.
I reinstalled wit Rocky Linux 9.1. so, sorry I can’t tell more : Log files are gone.

What I recall is that the LEMP : NGINX server was ON, etc… (using systemctl…) but could not access on the wordpress domainname:10000

I am in the process of reinstalling RL 9.1 and shall tell you how it goes, get you posted ASAP.


I admit not fully understanding the concept of FQDN (fully Qualified Domain Name), does the name there need to be different of the server’s (I guess Y).
A short example for WebServers neophytes like me may help.


FQDN is something.something.tld. It does not matter what you choose, as long as it is a name that will eventually resolve and is not a domain you will be hosting mail for on the server. If I wanted to host a domain named on my server, I might choose a FQDN of or or or or srv1.someotherdomain.tld. The name does not have to have any relation to any other names on the server, but it can, as long as it is not a domain name you will be hosting mail for in Virtualmin.

Then, I would make an A record pointing to the server for that name wherever I host DNS.

That’s it. There is nothing complicated about it.

It has nothing to do with the web server, though. It only matters for email. If you have a webserver or web app problem, it has nothing to do with the FQDN.

it works with the default CentOS/Rocky Linux 9.1 (XFS) : I may not have worked because I has a custom partitions, BTRFS etc…

But realize that now I may have to create a virtual server, (fail to work out a visible external IP address), in order to install Wordpress (script)?

I fine, it seems the documentation to simply install is inadequate (at least for me).
I was able to manually install WordPress in the past, a long procedure but it worked.
It would be great if I could complete this using Virtualmin !

Does it exist a bit more detailed step by step documentation ?


Of course. You need a website if you want to run a web app. Virtualmin is for managing virtual hosts in a web server and all of the related configuration one would expect from a “hosting” account (mail, database, etc.).

I’ve made a couple of videos aimed at your level:

  1. Virtualmin Introduction - A high level overview, but covers installing WordPress using Install Scripts.
  2. Installation and Initial Configuration on CentOS - A lot of depth about decisions you need to make when installing and configuring it for the first time.
  3. Creating a Domain - More depth on creating a domain, uploading files, etc.

I’m not going to say the videos are good, but they do answer a lot of your questions.

Right after the error, there is a link to the page in Virtualmin Configuration where you need to tell Virtualmin what your external IP address is.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.