Docker on virtualmin

**Operating system:**Ubuntu Linux
**OS version:**20.04.2
Is it possible to run docker container on virualmin server?
I am using virtualmin to host my website and would like to install a docker container app on one of the subdomain.

1 Like

Hi,

There are a thousand million ways to do this, cannot be in any way dependent on Virtualmin only…:slight_smile:

your base OS is Ubuntu Focal Fossa (Virtualmin is not an OP system), you do what you want, but remember Virtualmin only handles what that you created under him / her… (I don’t know yet if it’s a guy or a girl, sorry)

https://www.virtualmin.com/node/40622

+++edit:

https://www.virtualmin.com/documentation/cloudmin/virtualization/docker

Virtualmin don’t care if you run Docker.

You’d expose the port(s) or socket(s) for the apps in the container, and proxy to them in the web server, as usual. You can automate that with Server Templates if things will be consistent across some set of domains, or just set it up on an ad hoc basis. Running an app in a container is roughly the exact same as running an app server, from Virtualmin’s perspective: you proxy to it. (This is no different than in a non-Virtualmin system. It’s how it’s always done.)

This same question in various forms comes up daily lately. I think I need an automatic answer for “can I run X with Virtualmin” where the answer is “Of course. Proxy to it in the virtual host section, just like in a non-Virtualmin deployment.” Virtualmin uses Apache or nginx, so when you see instructions for how to deploy with Apache or nginx, those instructions will generally work just fine with Virtualmin (with awareness that paths may be different).

1 Like

This topic caught my attention because for some reason my Docker stopped working. I only used it for my Nextcloud instance to get the Collabora cloud-based LibreOffice to work. It’s worked for a lot of years, but a couple of weeks ago it stopped working. I’ve tried removing and reinstalling Docker on my Ubuntu Bionic to no avail. It never loads anymore.

Yesterday I thought, "would Virtualmin make a module to manage the Docker containers?"

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.