DNS zone created in Virtualmin but not showing up in Webmin

I’ve been fiddling with Virtualmin and Webmin on a brand new Ubuntu 18.04 VPS, but I’m baffled about how DNS is supposed to work. Here is what I did:

  • In Virtualmin as root, I created a new virtual server and chose “Bind DNS Zone”. I can see the records if I go to Virtualmin / Server configuration / DNS Records as root.
  • In Virtualmin as the virtual server owner, it does say “BIND DNS domain” in the enabled features. However…
  • In Webmin as the virtual server owner, if I go to Server / BIND DNS Server, it just says There are no DNS zones defined for this name server.

I could edit the zones directly in Virtualmin as root, but I’m trying to allow AXFR and from what I gathered, I have to do it from Webmin as the virtual server owner, not as root in Virtualmin. It’s as if Webmin doesn’t “see” the zone, or as if the zone isn’t associated to the Webmin user that owns the virtual server.

Note that this is strictly related to Virtualmin/Webmin, not with DNS records themselves. I’m not sure what I’m missing and I can’t find anything specific in the documentation.

Thank you in advance for any hints!


It’s known caching bug and @Jamie is aware of it.

To fix this, delete the following file and refresh the page:


Thank you very much Ilia, I wasn’t sure if I was missing something obvious. :slight_smile:

While I’m at it, let me ask something else: just to check that it was indeed a bug, I installed Virtualmin on CentOS 7 and that doesn’t seem to have the same issue. However, I’m confused about where I’m supposed to set up AXFR — it seems that I should have a “DNS options” button in the BIND settings page of Webmin, but it’s just not there, and nothing else seem to provide a way to fill in a list of allowed IPs. Am I supposed to something else to grant the Webmin user access to that submodule?

Thank you!