DNS Template error

Hello everyone!

I have an error in the DNS records every time I add a virtual server and it must be coming from my template but I haven’t found it yet.

I’m sure it is something very simple but I haven’t been able to find it.

Whenever I create a new virtual server BIND fails to restart and then after I delete the bad DNS record it starts just fine.

The DNS record looks like this:

Record Name Type Value
ns1.[servername].com ns2.[servername].com [new virtual server name].com. IN AAAA [IP6 address]

Any idea where this may be coming from?

I really appreciate any help with this!


Could you paste in an example of how exactly that particular record looks after it’s been added to BIND?



Looks like that one was more difficult to read than I realized.

Let’s try this

ns1.myservername.com ns2.myservername.com mydomain.com. IN AAAA FE80::0202:B3FF:FE1E:8329

Ahh, so you’re seeing all that on one line in the BIND zone?

If so, that may be the issue – I suspect that reference to ns1 and ns2 shouldn’t be there.

You may want to take a peek in System Settings -> Server Templates -> Default -> BIND DNS Domain. Do you see that line in the “BIND DNS records for new domains” textarea?


Thanks for the reply.

In that textarea I have

ns1.myservername.com ns2.myservername.com

Should neither of these be here?

Not in the way they showed up in your previous comment… is there any way you could paste in the contents of that textarea you have there? We could then help review what you have there, and how to correct it. Thanks!


I wasn’t able to attach the picture so I uploaded it here.


Is that enough info or do you need to see the whole page?

Ah, yes, that’s the problem :slight_smile:

Anything in that textarea needs to be a valid BIND DNS record. Those two nameservers are indeed domain names, but aren’t a complete DNS record, and would cause BIND to not start.

My suggestion is to remove them… and then, if you wish to use custom nameservers, just list those in the “Additional manually configured nameservers” field.


Thank you!