DNS stopped working, not won't restart

I installed Virtualmin the other day and everything was working fine. Today I find out the DNS is no longer running so I tried to restart it and got this:

“Failed to start service : Failed to start BIND : Starting named: Error in named configuration: /etc/named.conf:4: no matching ‘forwarders’ statement [FAILED]”

I can’t even FIND the /etc/named.conf file – it doesn’t exist.

It’s probably chrooted…check /var/named/chroot/etc/named.conf, perhaps?

I’m not sure why you’d get this error…I’d need to see the offending named.conf. Virtualmin doesn’t deal with forwarders directives at all, so it seems unlikely to be at all related to this error. But changes using other tools, or the Webmin BIND module may be involved.

I made a backup of named.conf and removed the " forward first;" line and bind was able to start and seems to be working fine.

What was the purpose " forward first;" and any idea how it got in there?

Thanks for the reply. Yes, it was in the location you pointed me to. named.conf:

[code:1]options {
directory "/etc";
pid-file "/var/run/named/named.pid";
forward first;
};

zone "." {
type hint;
file "/etc/db.cache";
};

zone "simcorinc.com" {
type master;
file "/var/named/simcorinc.com.hosts";
};
zone "bestincentivesolutions.com" {
type master;
file "/var/named/bestincentivesolutions.com.hosts";
};
zone "premiumsforincentivesinc.com" {
type master;
file "/var/named/premiumsforincentivesinc.com.hosts";
};
key rndc-key {
algorithm hmac-md5;
secret "EaSzbwkqOjR0ZUhvNXh+eg==";
};
controls {
inet 127.0.0.1 port 953 allow { 127.0.0.1; } keys { rndc-key; };
};
[/code:1]

This is a fresh CentOS 5 install. Immediately after installing the OS, I installed Virtualmin. I also installed Usermin.

Aaron