DNS slave config IP address problem

I’ve setuped my primary server on local network. I’ve tested it and everything was fine till I’ve move it to new location with new IP.

Problem is in secondary DNS server. In config file there is always written old IP ( as master server, but now master has new public IP. I’ve tried to set up everything once again, but I am missing something. I don’t know where to look for problem.

I’ve tried to grep 10.0.0 in /usr/local/etc/webmin on both servers but with no success - so I think it is not in configuration files - but I don’t understand webmin configs well enough to say it for 100%.

Thanks for any advice.

Sorry - my fault.

I was inspecting whole system for a few days and I was angry that I am so stupid and I cannot find one misstake.

For all of you who will encounter this problem in future - try to look into /etc/hosts file. There was written IP address for master server (old one) and I didn’t realize, that virtualmin takes IP from /etc/hosts primarily.