DNS Settings / SSL

OS type and version: Centos8
Webmin version: Webmin 1.981

Hello all,

after setting up Webmin on Centos8 with your help everything worked fine so far.
I managed to install WordPress and also upload videos via FTP.

Now i have a problem with SSL. I cant install it cause it fails with the acme challenge.
As I can see its a problem with the DNS configuration.

I tried a lot of solutions for hours and hours but just dont know what to do.
Im a Webdesigner and this area is completely not my topic.’

Error code for Lets encrypt Certificate:

main: www.d50547d2-idc.po.dinpo.com.br
  Type:   dns
  Detail: No valid IP addresses found for www.d50547d2-idc.po.dinpo.com.br

So the master zones were already setup after the webmin installation. so i was literally ready to go.

I can enter webmin via the domain d50547d2-idc.po.dinpo.com.br (
But for example the website i uploaded in the Folder with the same name that was there already is not reachable under this domain. Just if I type the IP

With the IP i end up in webmin. Whats the problem here?

For the information: my dedicated server has 2 IPS. So its a mess i totally dont understand. Thatswhy probably SSL has this issue.

Anybody a idea where to begin? …

Thanks a lot

I assume your main website is resolving OK and your nameservers have been setup fine?. When you created a new additional virtual server/domain - what ip address was assigned, shared ip or another static ip.

Hey Whoops,

tbh I have no clue. When I installed Webmin master zones and a virtual server was already there. So i just created a FTP login, uploaded my website and some videos and thats it.

Since I saw i can reach the website under a different static Ip then webmin i just used free dydns service to use a domain name for it.

So i wanted to activate SSL but dont work.

Current Status:

I open Webmin Interace over IP A and the content of my uploaded files via FTP oder IP B.

And if i want to install SSL it tells me IP is wrong, because it tries to install it on IP A and not IP B.

Try to change settings in the master zones since 4 hours, but no clue where to begin anymore and where to fix something.

You’re skipping over the first failure and rolling right on to the second, much less interesting one. Let’s Encrypt tries to validate first via a web request. This is the preferred validation method for a huge variety of reasons. Fix that one. Forget about DNS validation.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.