"DNS servers" in "DNS Client Options" does not hold the value

SYSTEM INFORMATION
OS type and version Debian Linux 12
Webmin version 2.105
Virtualmin version 7.10.0
Related packages SUGGESTED

The DNS server reverses back to 8.8.8.8 no matter what I put there. Is there a fix for this?

Are you set to pull from DHCP? Maybe the interface doesn’t offer all the configuration options?

These are the options I have on my home Debian 12. I’m pretty sure from past experience the “Automatic (Only addresses)” is what you are looking for but doesn’t appear present in the interface. But, default should be to save what you entered. This will let you set DNS, routes, etc…

I think the staff is still catching up with changes in Debian 12. I haven’t upgraded yet.

Yes, the network interface pulls from DHCP. When I change the interface to static, updates would fail. I am behind NAT using VirtualBox. I haven’t had the updates issue in previous versions of Virtualmin while using static IP.

chattr +i /etc/hosts. This will solve your problem in a faster way.

To remove overwrite protection: chattr -i /etc/hosts and you can edit the file again.

1 Like

It depends on your server‘s provider. I have Debian 12 on my personal computer and DNS stays the same. This issue exists because when you buy VPS or VDS, they install and configure your OS by their standards. Even Google Cloud instances use the same settings. After rebooting, /etc/hosts goes back to default. You need to make a file read-only.

It is real scenario?