DNS Server


I recently bought Virtualmin Pro. The first time we loaded it we made a mess of it and nothing seemed to work, we tried all sorts of things and got some advice from here but we were getting all sorts of errors.

We did a clean install again and this time it installed bueatifully and have not had an error message, we are very pleased with the installation.

I have got everything setup but my DNS Server does not seem to be working. I have created a master Virtual Server and edited the records in Bind DNS and as far as I can tell it is all set up correctly.

I have had my registrar create the following host records
ns1.cybernamixqld.com -
ns2.cybernamixqld.com -

I have setup the eth0 as IP Address and eth0 (virtual) as

I can access the server via both IP Addresses.

The server is called sv1.cybernamixqld.com in Hostname and DNS Client - Network Configuration

This is the records file from cybernamixqld.com

$ttl 38400
cybernamixqld.com. IN SOA ns1.cybernamixqld.com greg.cybernamix.com. (
38400 )
cybernamixqld.com. IN NS ns1.cybernamixqld.com.
cybernamixqld.com. IN A
www.cybernamixqld.com. IN A
ftp.cybernamixqld.com. IN A
m.cybernamixqld.com. IN A
mail.cybernamixqld.com. IN A
cybernamixqld.com. IN MX 5 mail.cybernamixqld.com.
cybernamixqld.com. IN TXT "v=spf1 a mx a:cybernamixqld.com ip4: ?all"
ns1.cybernamixqld.com. IN A
ns2.cybernamixqld.com. IN A
cybernamixqld.com. IN NS ns2.cybernamixqld.com.

I know it is propably something I have missed etc and I appreciatte anyones time who can assist me as I am getting frustrated.

Thanks again


Yes BIND is definettly running.

I ran the command locally and got

sv1:~# host cybernamixqld.com
Using domain server:

cybernamixqld.com has address
cybernamixqld.com mail is handled by 5 mail.cybernamixqld.com.

So it looks like a firewall problem.

I will talk to the firewall administrator and see if he can fix it

Thanks again

We are having trouble getting the firewall to not block it.

We have put in the following but it still seems blocked.

ACCEPT net dmz: tcp 53

Can you tell me what we should set?


Don’t worry, we have fixed it.

Thanks again for your great support.

Nice support request, Greg. Everything I need to know to be able to help is right there. (It’s rare enough to be worth commenting on.) :wink:

OK, so, troubleshooting DNS goes like this:

Is the registrar serving the right name servers?

$ whois cybernamixqld.com

Domain servers in listed order:

Yes, awesome. Are the name servers serving the right data:

$ host cybernamixqld.com
;; connection timed out; no servers could be reached

Hmmm…no. So there’s a problem.

Check to see if BIND is running:

ps auxc | grep named

Got a firewall blocking port 53? If it’s behind a NATting firewall, is that port being forwarded?

Does it work locally? (i.e. if you run the host command on the system itself.)