DNS - routing domain - broken link

Operating system: Unbutu Linux 20.04.2
OS version: Webmin 1.962, Virtualmin 6.14, Usermin 1.812

Operating system: Unbutu Linux 20.04.2
OS version: Webmin 1.962, Virtualmin 6.14, Usermin 1.812

Hy to everybody,

Thank you for great tool. I am newbie in Linux and servers. I have a basic question for which I cannot find easy answer, so please help.

I have a problem with domains or. domain security and broken links. I tried to make better security to set up SSL and check how email are working. I see that I have successfully route domains to my computer, but in the middle something is not working as it should DNS records.

WHAT HAVE I DONE:
I have successfully set up my server and routed domains to my server. From domain provider I have routed my domains to computer. This server is accessible thru subdomain.my1domain.com. Which has been directed thru A record to IP of my computer.

After I have created 3 different domains:

  1. First domain was create on name.com and then directed by NS name servers to hosting company. Because in hosting I can direct domain to IP. At hosting company I have written 3 A records:
  1. Second and third domains I have created at freenom.com, but here I had possibility from provider directly write IP of my computer, so that is all.

After I have created 3 different virtual server for each domain in Virtualmin. For domain from name.com I could even create Let’s Encrypt SSL certificate. For tk domain is Let’s Encrypt always reporting error when creating.

Because of this I tried to check
https://secure.fraudmarc.com
I get an error:
DNS error: no such host

If I am checking thru https://www.whatsmydns.net/ I see that this web page can only read A records and NS records. Both of these records are provided from other servers, not mine. But records of DNS which are on my server are not accesible in visible.

I can see that Virtualmin has created many more DNS records (dmarc, SPF, mail….) which are not accessible to the internet.

How can I solve that DNS records from my side will work as they should?

Thank you all for reply,

Miha

Hi Miha
You can check if your DNS works correctly using bind tools
dig www.domain.com @your_DNS

To check which DNS is responsible for your domain, simply use
whois domain.com

regards
Dimitar

Yes, the guilty party was my DNS.

I did not know, how exactly the work. After I managed my DNS records on the side of my server subdomain. I went to my provider of first domain where I had created subdomain which pointed to my server, everything started to work. No more NX error and failed certificate.

For my server I have then created two subdomains in created this records:

ns1.mydomain.eu. 14400 IN A “my IP”
ns2.mydomain.eu. 14400 IN A “my IP”
www.ns1.mydomain.eu. 14400 IN CNAME ns1.mydomain.eu
www.ns2.mydomain.eu. 14400 IN CNAME ns2.mydomain.eu
webmail.mydomain.eu. 14400 IN A “my IP”
webmail.mydomain.eu. 14400 IN A “my IP”
mail.ns1.mydomain.eu. 14400 IN CNAME ns1.mydomain.eu
mail.ns2.mydomain.eu. 14400 IN CNAME ns2.mydomain.eu
ns1.mydomain.eu. 14400 IN MX Priority: 0 Destination: ns1.mydomain.eu
ns2.mydomain.eu. 14400 IN MX Priority: 0 Destination: ns2.mydomain.eu

Then on Virtualmin:

  • VIRTUALMIN – DomainKeys Identified Mail – INSTALL NOW
  • enable Greylisting

Webmin:

  • under BIND DNS enable DNSSEC and RNDC

Waited almost two days on web page:

and other pages that DNS refreshed.

And after everything started to work.