DNS Problem after creating subdomains


I have a urgent problem with all my Websites

I have 8 Different Domains and websites running on my VPS

In the last 4 hour I created 40 subdomains using a selfwritten imacro-bot and virtualmin.
And now not a single website is working (no subdomain, no domain!). Even domains which were not involved in this, are not working.

After browsing a bit through my Virtualmin interface I noticed the following error message for EVERY single domain and subdomain, when clicking on “DNS records”

“Warning - errors were found in this domain’s DNS records : This domain has email enabled, but none of the MX records point to it. Either the MX records should be corrected, or the email feature disabled if mail is hosted externally.”

What might have caused this issue? And how to solve it? Please help me.

Thank you so much iin advance

I forgot to say:

For ALL subdomains, That I created, I changed owernship AND group to apache

Maybe this has caused the issue?

I manually changed owner and group to the default of these subdomains and after that I deleted ALL subdomains, that the bot created…

Still no success…

Please need some help.

Guy I found the problem…
it was actually something obvious.

My bot created a subdomain containing a unallowed character… that made the BIND DNS Server stop…

don’t put a ‘-’ at the end of your subdomains :wink:


Glad you got it working, thanks for letting us know how you fixed it!