DNS configuration questions with Virtualmin

Hi folks.
This probably isn’t the right forum, but I’ll ask it since I’m using Virtualmin GPL for the time being, and not professional, Though I would love to upgrade at some point.
What’s happening is that although my nameServers work, I’m unsure if my DNS server is authoritative for my doamin or nto.
Whenever an nslookup is performed by any client, loads of errors show up in /var/log/messages like the following:
Dec 29 13:06:41 serverbox named[1169]: error (network unreachable) resolving ‘34.97.191.88.in-addr.arpa/PTR/IN’: 2001:67c:e0::5#53
Dec 29 13:06:41 serverbox named[1169]: error (network unreachable) resolving ‘34.97.191.88.in-addr.arpa/PTR/IN’: 2001:500:13::c7d4:35#53
Dec 29 13:06:41 serverbox named[1169]: error (network unreachable) resolving ‘34.97.191.88.in-addr.arpa/PTR/IN’: 2001:dc0:1:0:4777::140#53
I could keep showing you examples of valid entries, but I edon’t think I need to.
First, how do I stop these rather annoying to review named messages?
Any help is appreciated from anyone who is using Virtualmin as an authoritative DNS server.

Howdy,

One place to start is with intodns.com – it’s a great place for testing your DNS.

For some details on setting on your server as a nameserver – you can review the section titled “How do I setup nameservers for my server” at this URL:

https://www.virtualmin.com/documentation/dns/faq

More details should be given.
I’ve already configured it for my own doamin.
What I’m trying to do is to configure it so that if other DNS servers wish to contact my server I can serv those systems as well.
In other words, I wish to be authoritative for my domain, but cache the results for other domains.
At the moment, however, if I try to make my machine use my DNS server and say ping google.com, I’ll get this in the server log file as an example only:
Dec 30 09:58:07 serverbox named[11953]: client 24.117.41.90#39634: query (cache) ‘lb._dns-sd._udp.0\013j\001\208\252\203/PTR/IN’ denied
Likewise if I try to do an nslookup as long as my DNS servers are selected:
Dec 30 10:07:14 serverbox named[11953]: lame server resolving ‘serverbox.keithnet.us.serverbox.keithnet.us’ (in ‘serverbox.keithnet.us’?): 64.20.56.34#53
Dec 30 10:07:19 serverbox named[11953]: lame server resolving ‘62.228.207.124.in-addr.arpa’ (in ‘228.207.124.in-addr.arpa’?): 211.147.6.4#53
Dec 30 10:07:21 serverbox named[11953]: lame server resolving ‘62.228.207.124.in-addr.arpa’ (in ‘228.207.124.in-addr.arpa’?): 211.147.6.3#53
Hmm, apparently I somehow hosed my DNS domain…
At the moment, I can’t get what I’d like to happen work successfully.
I am, already the master zone for my domain, wich isn’t the problem.
Any other thoughts?