Dnf update failing

OS type and version RHEL 8.6
Virtualmin version 7.0

I have tried “dnf update” on a couple of servers and both get:

Errors during downloading metadata for repository ‘virtualmin’:


Repos have moved (that’s why it’s still considered beta, we’re still changing stuff).

Remove the virtualmin-release package, and install http://software.virtualmin.com/vm/7/rpm/virtualmin-gpl-release.noarch.rpm instead.

Thanks Joe, that worked a treat.

I have same issue. I do not see virtualmin-release repo. Which one should I remove from this repolist?

[root@res3 ~]# yum repolist
repo id                           repo name
appstream                         AlmaLinux 8 - AppStream
baseos                            AlmaLinux 8 - BaseOS
epel                              Extra Packages for Enterprise Linux 8 - x86_64
epel-modular                      Extra Packages for Enterprise Linux Modular 8 - x86_64
extras                            AlmaLinux 8 - Extras
powertools                        AlmaLinux 8 - PowerTools
remi-modular                      Remi's Modular repository for Enterprise Linux 8 - x86_64
remi-safe                         Safe Remi's RPM repository for Enterprise Linux 8 - x86_64
virtualmin                        RHEL 8 - x86_64 - Virtualmin
virtualmin-universal              Virtualmin Distribution Neutral Packages

or do you mean to remove virtualmin-release 7.0-1.gpl.rhel from webmin > system > software packages
and install from http URL with http://software.virtualmin.com/vm/7/rpm/virtualmin-gpl-release.noarch.rpm ?

Just do this:

rpm -e virtualmin-release
dnf install http://software.virtualmin.com/vm/7/rpm/virtualmin-gpl-release.noarch.rpm

1 Like

Thank you, it works

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.