DKIM without BIND - Check OK, but nothing in mail header

I successfully setup DKIM (I mean no warning in Virtualmin) on a virtual server using remote DNS servers (using the given info).
The documentation says it is not supported, but I did not see any problem to add the appropriate records in the external DNS servers (appart removing the double quotes and line feeds in the key).
Actually, a check on is successfull (domain:, selector: 2015)

However, nothing goes out in emails. Example of an email sent from usermin:

Received: from localhost (HELO queue) (
by localhost with SMTP; 22 May 2016 16:05:39 +0200
Received: from (
by with SMTP; 22 May 2016 16:05:38 +0200
Received: from (localhost.localdomain [])
by (Postfix) with SMTP id D174D18A0072
for; Sun, 22 May 2016 16:05:37 +0200 (CEST)
Subject: test
X-Mailer: Usermin 1.690
Date: Sun, 22 May 2016 16:05:37 +0200 (CEST)
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary=“bound1463925937”
X-Ovh-Tracer-Id: 13596930225495968801
X-Ovh-Remote: (
X-Ovh-Local: (
X-OVH-SPAMCAUSE: gggruggvucftvghtrhhoucdtuddrfeekledrfeekucetufdoteggodetrfdotffvucfrrhhofhhilhgvmecuqfggjfenuceurghilhhouhhtmecufedttdenuc
X-Antivirus: avast! (VPS 160522-0, 22/05/2016), Inbound message
X-Antivirus-Status: Clean

Is their anyway I can make it work with remote DNS servers?
Or do I miss something else?

Thanks for help

Replied to myself.
Actually, the DKIM Virtualmin setup did not get through as I thought. Because I added several extra domains, it was happy. However, the concerned server was not processed as DKIM.
I just added the server domain in the additional domain and it works.

It was be wise to remove that constraint to have DNS enabled to enable DKIM: people who will dear to go at this place certainly know something about DNS records. The only annoying thing is the broken key.

jvieille :slight_smile: Happy to hear you resolved it
Another option is to activate both DNS and Mail features. Read more at