DKIM headers missing on outgoing e-mails

I am new to Virtualmin, coming from cPanel/WHM, I just didn’t want to continue to pay a monthly fee for a control panel.

I’m setting up a new server in-house, running Ubuntu 18.04 and Virtualmin installed via the script. Most things are going swimmingly, but I have encountered a few, what I hope to be minor, issues.

The most pressing issue right now is that my outgoing e-mails are missing any DKIM header. I have enabled the signing of outgoing mail under DomainKeys identified mail settings, and have tried generating a new private key. My domain is listed under additional domains to sign for, and saving the settings reports no problems. However, a test e-mail sent contains no DKIM header.

I have searched the forum for other similar issues and I can report that opendkim is indeed running, and I have tried restarting this service, but the issue persists.

Welcome to the community, @Adam_RG. Yes! :man_cartwheeling: No more monthly fees have to be paid for Cpanel if you use Virtualmin but that’s not the primary reason most of us prefer it. Virtualmin’s open, non-intrusive and modular approach lets admins offer web hosting options which are just not possible with proprietary software such as Cpanel. And Virtualmin differentiates your web shop from the five others down the street which use Cpanel.

Thank you, @calport, for the reply!

I did edit the opendkim.conf file and edit it to move the ‘#’ between the two lines. I also checked the /etc/postfix/ file and made sure the options you referenced were indeed present.

This alone did not solve my problem, but it did lead me to what the problem was. In my /etc/opendkim.conf file the line that I had to uncomment, “Socket inet:8891@localhost” was actually reading as, “Socket inet:8892@localhost” - Editing this line so that it reads “Socket inet:8891@localhost” has indeed fixed my issue, and DKIM headers are now appearing in my outgoing e-mails.

Thank you!

Ah. In the original message, I had mentioned ‘Be careful about the ports, the numbers might vary slightly for different installs of Virtualmin.’

Glad you got it working.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.