dkim-filter replaced with OpenDKIM

Hi,

I’m trying to setup DKIM but coming across an issue. Virtualmin keeps looking for /etc/dkim-filter.conf, but it appears that dkim-filter was deprecated and replaced with OpenDKIM. Are there any plans on updating virtualmin to use the new OpenDKIM?

I run webmin with virtualmin GPL on Ubuntu Server 15.04.

I’m not sure why did you go with Ubuntu 15.04 as you know EOL for this release is January 2016 so 3 months left. Virtualmin should use what it come with your OS (at least that was the case) so if your OS comes with dkim milter this is what you will get.

My suggestion is to use Ubuntu 14.04 (EOL 2019) and then see what you get for DKIM, if is dkim milter you can always manually install OpenDKIM and it will work. Only dowside is you wont be able to change settings from Vmin.

Howdy,

Virtualmin should be using opendkim on Ubuntu… however, Virtualmin doesn’t fully support non-LTS Ubuntu releases.

I’m wondering if there’s an issue where it uses the wrong DKIM config for that version.

As Diabolico mentioned I would recommend using Ubuntu 14.04, where it should properly use opendkim. I suspect that will resolve the issue.

-Eric

Hi, I’m using Ubuntu 16 and have the following problem when trying to automatically install DKIM:

Installing the DKIM filter package …
Installing package(s) with command apt-get -y --force-yes -f install dkim-filter …
Reading package lists…
Building dependency tree…
Reading state information…
E: Unable to locate package dkim-filter
… install failed!
… installation failed!

Any help is greatly appreciated.