DKIM; A public-key (p=) is required

I’m using Ubuntu 20.04

I can’t seem to get DKIM working. I tried copying and pasting an email I got back from check-auth@verifier.port25.com but as I am a new user I can’t post more than two links, which is kind of inconvenient. Here is a copy and paste from a checker instead:

DNS query failed for ‘202103._domainkey.420vapesessions.com’:NOERROR

A public-key (p=) is required

Is DNS being hosted on Virtualmin? I think not; you are likely hosting DNS via a third party service and you have incorrectly copied the DKIM DNS record from Virtualmin to the third party DNS service, triggering the error.

Text DNS records can be tricky and different DNS hosts want long records in different formats. AWS Route 53 is particular about receiving them broken up into chunks of 256 bytes while Rackspace and others accept long records in any which format and process them into RFC compliant DNS records on their own, thank you very much.

Check the format of the problematic DKIM against another which is known to work on the DNS server of the third party DNS provider, that should help you debug.

Considering when I change DNS records on Virtualmin they usually work I’d think they were hosted by Virtualmin, but I’ll check that out. Domain is hosted by 123-reg

My DNS is definitely hosted on my Virtualmin.

Then a copy / screenshot of the entire DKIM record, if it it shared with us via the forums, will enable the pundits here to comment on what the problem might be.