Disabling MySql using Server Templates

Hi all,

I have Virtualmin GPL installed in Webmin 1.441 in Ubuntu 8.04 with all the modules enabled.
Thanks to a thread that helped me resolve the suexec issue.
As of now, Virtualmin lets me do the thing in a jiff. :wink:

But now, I am having a issue in creating domains.
I am having a domain which will be the top-level server for all other domains.
In the sub-servers, some will have databases, some not.
So, How do I tune my template to achieve this.

I tried having a third template, using ‘create empty template’ with mysql disabled. But still when i select that template, database gets created.
IMO, its due to the ‘features and plugins’ setup.

Whats the solution to this, as i have some 90 sub-servers to be created.

As a workaround, Can i let MySql be enabled for all subservers and then after creation, will it be possible to delete the database and the access to it from Virtualmin?<br><br>Post edited by: vishnu, at: 2009/02/17 03:47

If you go into the Server Templates, and look at the "Default Domain Owner Limits" section, set "Default limit on number of databases" to "0" – that should prevent it from creating a database.

Hi Eric,

Nope, on your say i tried that, but creates a database.

It sounds like you may be using an older version of Webmin and Virtualmin; are you able to upgrade to the most recent versions and try again?

Thanks for the solution.
It works fine.

Also i have a small doubt.
How do i create a seperate mysql login for a subserver and not use the login for the main server.


Sure, if you select the sub-server from the dropdown on the top-left, and go into Edit Mail and FTP users, you can create a new user there specifically for database access.

If you click "Add a user to this server", go into "Other user permissions" to grant permissions to one or more databases.

Thanks andrey,
I tried that, it works.
Btw, i am using this Unchecking "Create Mysql Login".
This option works exactly for the cause i posted this thread.
Thanks again