Disable local mail delivery for virtual servers

I have the issue that is described here
but that thread seems out of date.

In my virtualmin Edit Virtual Server -> Enabled Features doesn’t have an options for mail only the following…

Apache website enabled? Webalizer reporting enabled?
SSL website enabled? MySQL database enabled?
IP-based virtual FTP enabled? Webmin login enabled?
AWstats reporting

None of our virtual servers are even going to have local mailboxes we always use google apps to handle mail so I’d like to set up things so postfix never tries to deliver locally.

Our name server / DNS / MX settings are handled externally too.

Our setup is
CentOS Linux 6.6
Webmin version 1.720 Virtualmin version 4.12.gpl GPL

Thanks for your help

I am having the same problem. For some reason, my hosting provider’s mail gateway had a glitch and rejected an outbound mail. The bounce went to the local mailbox. It was only by luck that I stumbled on the issue today.

In Webmin -> Servers -> Postfix Mail Server / General options, “What domains to receive mail for” had “$myhostname, localhost.$mydomain” as well as my main server domain. I removed everything but “localhost.$mydomain” and did a mail test from the server to email@server_domain. This time the mail was delivered remotely. I hope this change does not cause other problems.

Re-reading the original problem, my bypass does not allow disabling local delivery at the virtual domain level. /etc/postfix/virtual contains no references to any of my virtual domains - based on other posts, maybe virtual domain mail delivery was never enabled or is not supported in the current Virtualmin 4.18.gpl.