Different results from usermin and webmin for databases

I installed phpmyadmin, followed by the phpadmin module for usermin.

When I go into webmin->servers->mysql server, I see a number of databases: informational_schmea, myfirstserverDB, myserver_wp, mysecondserverDB, and MYSQL

When I go into usermin->Others->phpMyAdmin, first, I get the following error message:

Redirecting… (error: Error: Permission denied for http://localhost to get property Window.document from https://myserver.com:20000., if I click on OK, it goes away, and then I see the following databases:


and I cannot access the former databases from usermin. In addition these databases (though having the same name), have different numbers of tables.

The myfirstserverDB and mySecondServerDB were created using webmin, for those servers specifically. Any ideas?

What user are you logging in to Usermin as? You’ll probably only see the databases and tables the respective user has access to.

I am logging into webmin as root, and then from there, clicking on usermin. Usermin is not asking for additional credentials (or any credentials at all).

Where exactly do you “click on Usermin” in Webmin to log in there without being asked for root password?

Sorry, I meant I am logging as https://myserver.com:20000, and from there I click on the usermin menu item. The first time, it does ask for a password.

Hm, what I don’t really get is why you need a Usermin module for phpmyadmin… isn’t that a standalone PHP based MySQL management tool? What’s there to integrate in Usermin? What module is that exactly and where did you get it from?

Apache is also a standalone HTTP server. same for CVS, BIND, FTP, etc. I guess you can manage everything, standalone, and from the command line. The point of things like usermin and virtualmin, is that they put it all together, make it easier to manage, and consolidate stuff, so you won’t have to get carpal tunnel, or repeat the same task multiple times.

Oh, I see it now… It just adds a link to an installed PHPMyAdmin.

I just tried it and I’m getting the same error. Apparently the module redirects to a wrong URL… namely something on localhost. But there’s certainly no web server running on my notebook here. :slight_smile:

Seems some error in the PHPMyAdmin module, or it needs to be configured with the path to forward to. Or maybe it’s supposed to use reverse-proxy to embed the PHPMyAdmin in the Usermin GUI. I’ll let you know if I find out more.

@josephmo: Yeah, true, but Apache+Co do not have a web-based configuration themselves. PHPMyAdmin does, or rather, it needs no configuration at all. :slight_smile: So, no use “configuring” it from Usermin. “Embedding” it, maybe.

An error is a possibility. I don’t think that Sun (and Oracle they have MySQL since they bought Sun) have anything to do with phpmyadmin. It’s a third party app, used to manage the MySQL installation. The advantage of having it all in one place, is that you create a single user, and it’s spread to all the servers (MySQL, Apache,CVS, etc.), and when you delete something, it could be deleted for everyone, when you create a DB, the proper settings are created (users, etc.), so it’s a huge timesaver to have it all under a single roof.

Thanks for looking into this as well. I will continue digging.