Deprecated pam_stack module

From /var/log/secure I found

Jul 1 14:09:23 hostname proftpd: Deprecated pam_stack module called from service “proftpd”

What can I do here.

My first installation was from

Thank you

yeah i’ve seen this line in my logs too.

How I see this. Some pam module isn’t actively being developed anymore and not supported by developers. It doesn’t mean the module isn’t working.

There might be something else to replace it, but I wouldn’t know about that.

So, just to clarify – are you actually having FTP login trouble?

Sometimes warnings will show up, even while things continue to work fine.

But, if you’re having troubles, what problems are you seeing exactly? And what distro/version are you using?


I only tested once the ftp access in this new server and it was okay.
I just was watching /var/log/secure for other reason and I found that.

i actually looked into it a bit deeper and this seems to be around for a longer time. it also seems to be a bug in PAM which can be (partially) solved. that is get rid of the message I have found:

These lines in /etc/pam.d/proftpd need to change:

auth required service=system-auth
account required service=system-auth
session required service=system-auth

auth include system-auth
account include system-auth
session include system-auth

I havent done this myself though

This is a bit of a regression in my proftpd package (actually the EPEL package, as I switched to the EPEL version a while back). I’ll roll a new package for CentOS/RHEL 5 soon that corrects this message.

Hi Joe,

I have just seen the same error appear again in my logs.

Operating system CentOS Linux 5.8
Virtualmin version 3.92.gpl GPL

Login seems to work fine, just see these errors in my logs.

Let me know if there is anything I can do to help



What output do you get when running this command:

rpm -qa | grep proftp


Hi, here is the output.

rpm -qa | grep proftp


Ah, it looks like you’re using the ProFTP package from the RPMForge repository.

My recommendation would be to stick with packages from the standard repositories, unless there’s a specific package from that repo that you need.

There may be something within the RPMForge ProFTPd package that’s causing that notice that you’re seeing in the logs.