Deleting Old Backups

OS type and version: CentOS 7.9.2009
**Webmin version:**1.979
**Virtualmin version:**6.19
**Related products version:**Authentic Theme 19.83-RC4-3

I need to gain a better understand of how the auto-deletion of old backups work. The documentation states that you must use a date based naming for this to work. However, I have had this turned on now for 2 months (both FTP (FTP turned off over a month ago) and AWS setups) and it has yet to delete backups over 30 days old. I am using AWS S3 as my backup storage. The emails that I get from the system clearly state it is not deleting and the AWS S3 still show the backups.

I feel like I am missing something. Here is a screenshot of the settings I am using:

Does anyone have any idea as to why backups aren’t deleting?

@Jamie have we already fixed in upstream an issue with deleting old backups when strftime-style time substitutions on file/directory is used?

Do the buckets you’re creating have names starting with [D]- ?

Yes they do. I originally had it at the end but never worked.

I’m wondering if the [ ] characters are causing problems somehow?

@Jamie so I tried removing the [ ] characters and changed the age date to 3 days and it still doesn’t work.

What am I doing wrong?

What output do you get if you SSH into your Virtualmin system as root and run virtualmin list-s3-files --bucket www-backup-guava --multiline

That will show if the dates are being parsed properly by Virtualmin.

Sorry for the delay, it is now working as it should. Just took some time to get going.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.