Delete old backup not working

OS type and version Almalinux 8
Webmin version 1.984
Virtualmin version 6.17
Related packages scheduled backup

Hello, i have a server with virtualmin (only hosting 1 website) and i must backup on remote ssh server.

i setup backup like picture, works fine but on remote server i find
2022-02-07–00-00 folder (with date 2022/02/07 - 01:57:49)

why virtualmin don’t delete this old backup?

thank you


It may be due to the formatting of your date string causing the pruning job not to work.

Not at my desk right now however, so will have to look into further later.

thank you for reply.

can i suggest a formatting can work?

my goal is have folder / files sorted with date , to have a clean reading in case of restore.

thank you in advance

Between %d and %H you have a double ‘-‘. Should be single?

Can also try:


thank you
now i’m try with single -

i write double to clearer display…
but is not big problem…

i try with single -

thank you again


Edit, I do backup everything to local hdd (spinning one) and every time backup finishes I do ssh to another machine with rsync which sync that hdd to another server outside (its all automated via bash scripts… after initial point of backup from virtualmin gui) - that server then sync back to my home server located in my home country… so I have multiple locations of this just in case fire or whatever happens… I hope so you can read that popup on screenshot… you can enlarge image by click it on it.

ok thank you for reply.

so only way to work is to use %d-%m-%Y (without hour and minutes).
ok now i try with single -
in 10 days i say if works, and in case change name…

thank you

@ale.ab the screenshot is saying it all… you use strftime within the backups… do you know how this works in linux at all?

also remember that changes if you just copy this over ssh somewhere - it will be the time you copied - even milliseconds makes difference on linux. On linux backup 00:00:00:00:000 is not same as ssh and then copy it out. Basically even backup happening on remote server as connection and file transfer will take some time Yes minutes and seconds and milliseconds in name does not make difference as you are about precise carbon copy you want.

Backup on local hdd or file system with virtualmin gui and then use rsync to prevent any changes to strftime and file permission etc and copy will be exact carbon copy of the files (unless I missed something) and then it will work…

you can also use rsync to actually sync two or more machines - meaning if one machine delete something other machines will replicate and follow… same for adding anything… You basically work on file/folder metadata instead of names.

  • I hope so it will helps.

edit: please notice wording - copy vs replicate !=same. Thanks.
edit2: you can name your file whatever you want even with minutes and seconds - its strftime in your copy or carbon copy which make it all… not the name of the fille :wink:

ok, thank you
i would use hours and minutes because sometimes i running backup multiple times on a day.
so i have visually when backup startec (of course is not accurate on seconds).

so on remote server (ssh) i run “ls” i find quicky what I’m looking for …

for rsync is good options , but i would have control also of remote transfer.
so if i schedule a local backup and then rsync to remote server
i have mail only if backup is ok on local, if rsync “wrong” i can’t know…

i’d rather mount remote server with sshfs and backup on /mnt/remotessh/…
so if virtualmin send me mail with backup ok , i’m feel more secure :slight_smile:

now for almost of my servers i use this procedure
mount with rclone a google drive space (where i have unlimited space) and backup “local” to /mnt/googledrive/…
of course in this case i keep all my backup (never delete old)

but on this server i can’t use google drive as target , and i need to backup on a remote ssh server…

thank you again

Hi @ale.ab ,

I did explained everything clear to you already…

I am free to troubleshoot your issue all week days in mornings for 8am to 7pm of GMT (or UK time). Since I can see that you would not understand my enquiry to help you with this issue, I would rather help you via zoom, signal or telegram video call. This service is outside of the scope of free and its paid service and expertise form me. I can help you to troubleshoot your issue in no time. Please let me know when you are free and I will send you hire me link where you would be able to pay for pro support from me or I can point you to virtualmin guys who can trouble-shoot your issue in no time…

Thank you.

edit : I know what rclone is and you would not want to use that for backups… anyway as my msg said above. - thanks.

ok, thank you.

is not a problem. i unserstand is my limit.
so can you send me a price quotation for your services, so i evaluate and in case organize a video call.

i’m sorry if i offended you, i could not find error in my backup setup. so i ask in forum…
now i learned a little more, but is not a problem have someone to ask in case of need.

thank you

after ten days i confirm that not work with single -

so now i change my idea to write also hours/minutes and now i set

I hope I have no problems

thank you

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.