Default website leads to failed LetsEncrypt?

/edit/ I have fixed the default website issue. I have made a dummy vhost, made it default, and have put an empty index.html file inside its directory.

Thats does not fix my LetsEncrypt issue, but it appears to be a known issue. To bad the ticket is 2 years old. So i’m not really thrilled to see it being fixed soon ^^


I’m new to VirtualMin, so I have to warn you that this might be a stupid question, anyway here it goes.

I’m running a Virtualmin, and I have put a LetsEncrypt certificate in it.
Now I was adding a new virtualserver with SSL enabled. I created some a records for it; / webmail / admin etc etc (external A records, not using virtualmin as NS).

When I wanted to generate an SSL Certificate I got an error, and I could see drupal tags inside it… I thought mmm how is that possible, the webspace for
this newly created VM is empty? So I did the test! browsing to and I see the website of the first vhost… :frowning:

Every A record that I make, goes to that ‘default’ website. Also when I enter the http address instead of the https adress for my virtualmin page I see that same default website.

I googled, and found this; “Server Configuration -> Website Options -> Default website for IP address.” But it is not there (or i’m looking over it…).
If it doens’t exists it should show a 404 or something instead of redirecting. If I can stop the redirecting, will I be able to create an SSL cert for it?

The reason I’m asking that (I might be wrong) I want to be able to use and with a correct SSL cert?
Or am I doing that wrong?

Sorry for the long post. Beginner :slight_smile:

Best regards,

I have edited begin post.

This is the issue I’m referring too;

Hi Jordy
I have also just started trying Virtualmin and had a similar issue to yours…
My issue was all about DNS - so if you are testing a server it is easy for you to go to your domain registrar or the current control panel controlling your domain and just add an A record pointing to your new Virtunalmin server - everything will work website wise but you are not using Virtualmin DNS .

What you would need to do is update your name sever records with your domain registrar or similar to the records you setup when setting up Virtualmin and than wait 24 /48 hrs for this to propagate through the internet … Now you can use Virtualmin DNS

Also I found that I needed to have the domain pointing to my Virtualmin server and have created web hosting space for LetsEncrypt certificate to be issues

Hope this helps