Default shell

How do I set the default shell of the user created when a domain is created. /bin/sh is a very lame choice, I want /bin/bash. How do I do that? OS is CentOS 6.2.

Check out Virtualmin / System Customization / Custom Shells.


Also, bash should indeed be the default shell used for new users as of Virtualmin 3.94.


I can confirm what Eric said. My fresh 3.94 test installation has the default admin shell set to bash.

For my 4.00 Virtualmin, the default shell for non-admin users is sh, not bash. Although root defaults to bash…

Nonetheless, it’s easy to change as noted above.

As a side note, to change the initial shell for existing users, use the webmin --> users and groups module.

Each user has a default shell option.

Failed to save custom shells : Non-existent shell in row 5