default domain name was incorrect

hello all -

when i was pointing a domain name to my server without yet going into virtualmin and creating a virtual server, the incorrect domain was coming up.

in other words, say my initial domain was:

then i created these virtual servers:

now, suppose i buy the domain “” but have not yet created the virtual server for it. when i go to in a browser, newbie-guy-ONE shows up!

i want to show up instead, at least until i actually create the virtual-server.

the only way i could think to solve this was to go in and manually edit my httpd.conf file, and make absolutely sure that is the very first

that worked, but i never feel comfortable editing httpd.conf so long as the world has such wondeful tools like virtualmin!

any other ideas?

That’s very simple to understand.

To understand the concept:

What is happening is is set to be configured as default host and can be accessed via ip.

So what is happening is: + ip > + ip > + ip >
unknown domain (no virtual server created) + ip >

To fix it, goto’s settings in virtual min,

then goto Server Configuration > Change IP Address and make it so.

You may also need to remove the private address for

Do let me know if it does not work, then I’ll guide you thru the httpd.conf.