Debian amd64 Install

Close, but not quite there. Looks like I’m having some problems pulling from the virtualmin repository. X’s added by me…

Failed to fetch http://xxxx@software.virtualmin.com/debian/debian/dists/virtualmin-etch/main/binary-amd64/usermin_1.280_all.deb 404 Not Found
Failed to fetch http://xxxx@software.virtualmin.com/debian/debian/dists/virtualmin-etch/main/binary-amd64/webmin_1.360_all.deb 404 Not Found
Failed to fetch http://xxxx@software.virtualmin.com/debian/debian/dists/virtualmin-etch/main/binary-amd64/apache2-utils_2.2.3-50_amd64.deb 404 Not Found
Failed to fetch http://xxxx@software.virtualmin.com/debian/debian/dists/virtualmin-etch/main/binary-amd64/apache2.2-common_2.2.3-50_amd64.deb 404 Not Found
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Bug or just down? Authentication ? wondering what’s up?

Thanks,

Ron

I see the problem, an extra debian in the dist. I’ll see if I can update manually, but you need to take a look at the path.

Oops. Crap. I just can’t stop breaking those Debian/Ubuntu repositories.

Thanks for the heads up.

Try it again. Be sure to apt-get update first.

Yep, fixed now. All was well until I rebooted. It upgraded the kernel right before and I’m administering remotely, so I have to wait for a body to get in front of it. But I saw Virtualmin up and in operation prior to that - Thanks!

Ron

Ok, hope this helps to work out the kinks.

My brother had just left the CD in the drive when I booted the server, no big deal there.

However, when I did the check config for Virtualmin to get started I get this:

BIND DNS server is installed, and the system is configured to use it.

No virtual domains file was found in your Postfix configuration. Maybe no virtual domain map has been defined.

Looked at the Postfix setting for Virtual Domains and it says this is the file:

hash:/etc/postfix/virtual

File did not exist, so I created and set permissions as they were on my local test server.

then I touched the file.

[code:1]touch /etc/postfix/virtual[/code:1]

set permissions

[code:1]chmod ugo+x vir*[/code:1]