Debian 9 Virtualmin 6 cannot create site


Have used Virtualmin a lot before but installed new 6 release with Debian 9 and when going to index page of new site, I get the Apache default page.

Directories and files have been created as usual in /home/sitename/publichtml/

Hmm…the default site is supposed to be disabled during install. Did all of the configuration steps complete? (There would have been numbered steps during phase 3 of the install, labeled with numbers like “[3/23]”, “[4/23]” and so on…obviously we’d want to get to 23/23.)

You can try re-running the Apache configure plugin with:

# virtualmin config-system --include Apache

If that doesn’t fix it, and there are no errors, we’ll need to look at the config files, particularly the main config file and the contents of sites-enabled (000-default.conf shouldn’t not be in sites-enabled, but it must be if you’re able to see it). I’m guessing there’s a problem with the VirtualHost sections, probably an IP mismatch somewhere that makes apache fall all the way back to the default site. (But, again, default site shouldn’t even exist in the active configuration if the Apache configuration step ran.)

Hello Joe
Thanks for the reply and sorry for taking so long to get back to you.
I have tried setting up a completely new linode and this time I cannot even get as far as the Virtualmin control panel, but just get the Apache page.
If you want to have root access to either or both Linodes, please let me know. If you have access to my email, please fell free to drop me a note.
Thanks very much

If you see Apache when trying to reach Virtualmin, you’re visiting the wrong port! :wink:

Virtualmin lives on port 10000. Apache will never be running on port 10000.

Browse to: https://your.server.address:10000

The installation runs OK but have noticed that at the finish it says go to:
whereas it normally says:
Don’t know if that’s a clue.
Can access my FQDN:10000 and go through Virtualmin checking and update routine.
Did get a “You are not authorised to access / on this server” before putting index.html in html directory, then everything reverted to apache debian page or server taking too long to respond message.

You’re on a dynamic IP address, am I right?

That means every time you get a new IP all of your virtual hosts will break, because they have the old IP. Virtualmin should detect this change, and offer to fix it. You could also switch to using * instead of an IP in your VirtualHost definitions. This has some other negatives, but you’re never gonna have a nice time hosting a server on a dynamic IP address. But, I use * on my Scaleway server that has a dynamic IP, just so I don’t have to deal with IP changes. Virtualmin doesn’t really make * VirtualHosts easy (because it’s almost always a bad idea, particularly on a system with more than one IP and lots of virtual hosts). But, for a small personal server or one only hosting one website, it’s fine.