Debian 8.5

Had to rebuild a server from scratch so i used the debian image i found @ my hoster, which is a 8.5 minimal. So i had the OS installed and put the virtualmin install script in, gave it 700 and told it to run.

It does quite a lot but in the end i am missing the normal “You can now login under … :10000”, and that is correct, since i cannot login. The last part of my installation log on screen tells me:

webmin is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.
INFO - 2016-09-07 18:23:26 - /usr/bin/apt-get --config-file apt.conf.noninteractive -y --force-yes install bsdutils postfix postfix-pcre webmin usermin ruby libxml-simple-perl libcrypt-ssleay-perl unzip zip libfcgi-dev bind9 spamassassin spamc procmail procmail-wrapper libnet-ssleay-perl libpg-perl libdbd-pg-perl libdbd-mysql-perl quota iptables openssl python mailman subversion ruby irb rdoc ri mysql-server mysql-client mysql-common postgresql postgresql-client awstats webalizer dovecot-common dovecot-imapd dovecot-pop3d proftpd libcrypt-ssleay-perl awstats clamav-base clamav-daemon clamav clamav-freshclam clamav-docs clamav-testfiles libapache2-mod-fcgid apache2-suexec-custom scponly apache2 apache2-doc libapache2-svn libsasl2-2 libsasl2-modules sasl2-bin php-pear php5 php5-cgi libapache2-mod-php5 php5-mysql ntpdate: Succeeded.
INFO - 2016-09-07 18:23:26 - Updating SpamAssassin rules…
INFO - 2016-09-07 18:23:31 - Rule updates done

So, how to run it to the very end? Fire it up again? It seems to me, that there are still some parts, not unimportant to virtualmin, are missing.

Thanks and best

PS: I have only CentOS, Suse 42, Ubuntu 16.04 and Debian 8.5, so i thought, given, that i am not into Fedora / Redhat / Suse, best bet would be Debian …


Hmm, that script output actually looks normal… the Webmin message wasn’t displayed, as it appears that it thinks Webmin was already installed prior to running the installer.

It may just be a matter of starting it up – what happens if you run this command:

service webmin restart

root@server02 /etc # service webmin start root@server02 /etc # service webmin restart root@server02 /etc #

So it should be installed, but i cannot connect, which is bad, because i cannot configure :frowning:

Does it harm, if i run the installer again?, but wait, i had a look in the log file again:

newaliases: fatal: open /etc/postfix/ No such file or directory

or also a lot of these:

Subroutine get_dnskey_record redefined at /usr/share/webmin/bind8/ line 947. Subroutine record_id redefined at /usr/share/webmin/bind8/ line 969. Subroutine find_record_by_id redefined at /usr/share/webmin/bind8/ line 978. Subroutine get_dnskey_rrset redefined at /usr/share/webmin/bind8/ line 997. Subroutine is_raw_format_records redefined at /usr/share/webmin/bind8/ line 1019

looking into the file, it ends with this:

Run sa-update if installed, to ensure spamassassin rules are recent

which sa-update >/dev/null 2>&1
if [ “$?” = 0 ]; then
logger_info “Updating SpamAssassin rules…”
logger_info “Rule updates done”

so it seems it ran correctly, but shouldnt be there something more at the end? in the past i think, i remember, that after installation it gave a thumbs up and the information, that i am able to login to webmin … etc.

i did a reboot, but it wouldn’t help either. So what to do?

another update. I did a reboot again and tried to access it via its domainname(no avail), then i tried it, as before with ip adress (which didn’t work before) and now i am in and can start to configure…

Well, better now, but i am anxious whether all server migration will run smoothly. I will select using suexec this time and also make use of fcgi. Hope then it will work out somehow everything.

On one hand, the installer appears to have completed successfully.

On the other hand, there’s a lot of strange stuff going on there. The main Postfix config is missing, suexec isn’t installed, and Webmin isn’t answering queries.

If your server isn’t live yet, it might not be a bad idea to re-run the installer… mostly to ensure that the necessary dependencies have all been installed.


Later on yesterday night i had webmin up, don’t ask me why and how it finally worked out, and i even had my websites which i had to move there including certs, which also worked out after having forgotten how to set it up. Then i shut down mysql server and copied the copied folder of the database into /var/lib/mysql, but having backed up the old database before.

Then MySQL went crazy and told me, that there wouldn’t be any database. Restart MySQL, now i saw all the databases, but i couldn’t use them i got an error like this : Can’t open file ./mysql/usr.frm24. I looked around for a solution, but found none. Then i thought, perhaps reinstalling mysql would do the trick. No way. In the meanwhile i trashed the folder i put in /var/lib/mysql and put the old one back. But no avail.

So i ended up in throwing everything away and rebuild from scratch. This time everything went smooth, and instead of 6 hrs trying to fix the old server and another 6 hrs installing and fixing the new server, it was just 3hrs and everything was up and runntn. Very strange, indeed. But it seems to work now, although i will have an eye on this specific server for a while.

Thanks and best

btw, the is being created but later in the process, so i am wondering why this is this way.

Concering this: Can’t open file ./mysql/usr.frm24 i could have saved time if i found the post somewhere else earlier, stating, that there are already too many open files. changing or adding the open_files_limit with a count of 10000 would have fixed it, which it did, when i had this one again later on.

Also, no mails came in or out. What i am really missing is a script in the background, taking care of using certificates for email. Some menuoption as the like:

Send Emails over encrypted connection to hosts mailserver. Then it checks for an existing certificate for postfix / dovecot and sets all settings accordingly for smtpd.conf, saslauthd, postfix, dovecot.

I ended up in checking one server, where i knew, it was working with that, so i opened that Ubuntu thing and checked for settings and adjusted accordingly. I still have no success in sending via encrypted connection to mailserver, but i can send emails, which is more, than i had beforehand.

Likewise, should i prefer Ubuntu over Debian or vice versa?