debian 7 + virtualmin could not load mod_fcgid

Dear Sir/Madam,

I’m sure that I change in Server Template to FastCGI module of apache2. But when I try to access my php code did not work. when I check module of the apache2 I saw this.

root@server03:/var/www# apachectl -t -D DUMP_MODULES |grep php
Syntax OK
php5_module (shared)

could you please share me idea about this?

Best Regards,


The output you’re receiving for the apachectl command is normal.

What PHP problem are you seeing? Is it throwing an error in $HOME/logs/error_log?

Also, do you see any errors in /var/log/apache2/error_log?

Also, if you think you’re seeing an fcgid issue, you could make sure that module is enabled with this command:

a2enmod fcgid

hello here is the error

Fri Jun 19 21:07:50 2015] [notice] Apache/2.2.22 (Debian) DAV/2 SVN/1.6.17 mod_fcgid/2.3.6 PHP/5.4.41-0+deb7u1 mod_ssl/2.2.22 OpenSSL/1.0.1e configured – resuming normal operations
[Sat Jun 20 07:25:31 2015] [error] [client x.x.x.x] Invalid method in request \x16\x03\x01

hello thanks for you help me Eric. I already found that my server is running FastCGI php mod.

thanks you so much.

I would just off topic about permission folder and file in debian when I create virtual server it was create a folder in /home/ but all permission folder are not 755 but it 750 and file is not 644.

I would like to ask you that how to set auto permission all folder 755 and file 644 in debian?

sorry for dummy question.

Best Regards,